Adding Foscam C1?

Free domotica! Forums How can I …? Synology NAS Adding Foscam C1?

Tagged: ,

This topic contains 18 replies, has 4 voices, and was last updated by  hgravatar 1 year, 10 months ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #2201

    hgravatar
    Participant

    I would like to add my Foscam C1. How can I accomplish this?

    Kind regards, Henri

    #2203

    K.Rens
    Keymaster

    I’m getting one for Chistmas in a few days, with the family.
    Then I can test it and give you detailed instructions.

    You can add it as a virtual device: camera
    http://192.168.1.xxx
    Port 88
    Flux: /cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=admin&pwd=YOUR_PASSWORD&t=
    And leave the rest empty.

    Kind regards,
    K.Rens

    #2209

    hgravatar
    Participant

    Can’t get it to work. The usr & pwd are the username and password for my Pulsestation instalment, right? I used those credentials, but when I go to my User Interface, the dashboard is totally empty. As soon as I remove it from the dashboard in the administration part, the other device appears again in my User Interface dashboard. So I’m not sure how to go about it. Can I test the virtual device somewhere in the administration side of Pulse station?

    Good choice. It works good with the Foscam app itself. Just let me know if you get it to work.

    Kind regards, Henri

    #2221

    K.Rens
    Keymaster

    Hi,
    Don’t fill in a username and password in the parameters, put the username in the usr field in the url and your foscam device password inside the pwd parameter in the url.

    For the dashboard you also need to add this device to your dashboard.
    Press “+” and choose Camera panel.
    Type of device: virtual camera.

    I haven’t opened my packages yet, can’t wait for them 😉

    Kind regards,
    K.Rens

    #2230

    hgravatar
    Participant

    Tried it again, but I can’t get it to work, unfortunately. I hope you’re doing better, so I can see how you did it.

    #2253

    hgravatar
    Participant

    Found the problem. I used the wrong IP address. Now it works on the dashboard 🙂

    Can you only view a snapshot? Is there a way to start the motion detector of the Foscam? I would like to be able to turn on and off the alert function for activity and sound. Or can I only use the Foscam app for that? It would be great to be able to use only 1 app 🙂

    And it shows up on the dashboard, but I can’t find it in the ImperiHome app? In list view it shows 2 empty pages. On the other pages it shows my two switches, the yahoo weather widget and a blockly rule.

    Did you get it to work already and have you tried to run it on ImperiHome app?

    #2254

    K.Rens
    Keymaster

    Glad to hear it’s working.

    Without plugins in your browser you cannot have the stream, only the image.
    We do not have such a plugin at the moment.

    For controlling your device:
    if you can change it’s setting by calling a url, you can add it as a new device (virtual url).
    Then you can change the settings by calling the url.

    Inside Imperihome you can add the device as a new system.
    It’s like adding PulseStation the first time in imperihome, only now you add a camera device.

    I will get it only the day after newyear, then we open the gifts…

    • This reply was modified 1 year, 10 months ago by  K.Rens.

    Kind regards,
    K.Rens

    #2261

    hgravatar
    Participant

    I’ve got in running by setting up the new system (ip-camera). I looked also for a url for changing the setting on the website of foscam, but can’t find it. So I guess they don’t support that. Too bad.

    Thanks for the info and have fun on the first day of the new year 🙂

    #2262

    K.Rens
    Keymaster

    You can look in the NET panel of your browser what request is sent to your foscam.

    Google for:
    Chrome NET panel
    Firefox NET panel

    In order to find it.
    Then record the request and see what is sent to foscam when you change the setting.

    Kind regards,
    K.Rens

    #2271

    hgravatar
    Participant

    I figured out how to apply different urls. I found the user guide for CGI foscam. You can find it here:

    Userguide Foscam CGI

    From this guide you can request the right parameters by playing around with the web interface of Foscam. Set the various settings in the Foscam web interface and use the url which settings are set. For the motion detection I used the following url:

    [ip-cam]:[port]/cgi-bin/CGIProxy.fcgi?cmd=getMotionDetectConfig&usr=[USERNAME]admin&pwd=[PASSWORD]

    It also has a set url command. I’m using the following:

    http://[ip-cam]:88/cgi-bin/CGIProxy.fcgi?cmd=setMotionDetectConfig&isEnable=1&usr=%5BUSERNAME%5D&pwd=%5BPASSWORD%5D

    It works in safari. And now I’m trying to add this url as a virtual url in PulseStation. I add the url to the Virtual Devices service as a Virtual Url. And then I add a panel in the Dashboard. I chose the One Button Panel. However, when I start the PulseStation interface I see the panel and I can click it, but the setting on my camera doesn’t change. When I use the same url in the browser again, it does change the setting.

    What am I doing wrong?

    #2300
    Mika
    Mika
    Keymaster

    You have to configure your “virutal device camera” correctly with the infos you have.
    And then add a “camera panel”

    #2303

    hgravatar
    Participant

    Hello Mika,

    thanks for your answer. I already have the camera showing a live picture on the dashboard by using the virtual device camera and the camera panel. The virtual device only shows the camera. I want to be able to turn it on/off remotely. Hence, K.Rens advised to use the virtual url. I have the correct url, because it works when I use it in the browser. But when I’m trying to add it as a virtual url in PulseStation and the one-button panel, it doesn’t work. I use the exact url that works in safari. See also my previous post above. What am I doing wrong?

    #2332

    K.Rens
    Keymaster

    Can you check whether your synology is able to make an external call to that ip and port 88?

    Kind regards,
    K.Rens

    #2339

    hgravatar
    Participant

    Hello K.Rens,

    Can you tell me how I can do that? I’m a newby to the Synology world 😉

    Did you get your Foscam running already?

    Kind regards,

    Henri

    #2352

    chicagolandjim
    Participant

    Just want to say thanks for all your work. I am senior newbe and have a Synology NAS and have loaded the software but am unable to go much further. I also have a Foscam camera and have tried to follow this thread to implement. So far I have created a virtual device called a virtual camera with a name of Foscam and for the location, I put in the URL(probably the wrong place). I have created a Camera Panel with the virtual Camera. After generating panels, I get an empty screen and I do have the the theme and layout set to Default. I see no place to enter the URL of the camera. Where do I go from here.

    Once I have this figured out, I will be happy to help with step by step instructions in English for all the others and either post it here on the forum or a WIKI.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.