CAM virtual device

Free domotica! Forums How can I …? Synology NAS CAM virtual device

Tagged: 

This topic contains 7 replies, has 4 voices, and was last updated by  Coyote 1 year, 10 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #886

    jerem
    Participant

    Salut,

    Petite question, je n’arrive pas à configurer un périphérique CAM.

    C’est une TrendNet TV-IP310PI, elle est configurée sous SurvStation, mais je n’arrive pas à trouver le lien http du flux direct, donc j’ai essayé avec le rstp que j’ai trouvé, mais ça ne fonctionne pas.

    Des pistes ?

    #888
    Mika
    Mika
    Keymaster

    Pas vraiment de piste, généralement il est possible de trouver les infos nécessaire sur le flux via google. Si vous avez une url qui fonctionne dans un navigateur, elle devrait en principe fonctionner avec PulseStation.

    #1193

    Coyote
    Member

    Hi Jerem, Hi Mika,

    I have troubleshooting with my HD Cam (Foscam)too. In fact, you can’t read the HD stream directly.
    But you can modify parameters of the cam to stream in Mpeg rather than HD.

    I’ve done this modifications, and it now works with ‘http’ command on an Internet navigator.(You keep main stream in HD, and sub stream in Mpeg)

    But after this, I have problem with the ‘camera.flux’ parameter.
    I try to put my command line with login conditions (with my MYUSR and MYPWD variables of course):

    /cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=MYUSR&pwd=MYPWD

    But it doesn’t work. So I have a question.

    How does the application compile different parameters ?
    I try to put MYUSR and MYPWD in the camera.username and camera.password too, with no result.

    Is it possible to have this two fields (camera.username and camera.password) like variables to create the ‘camera.flux’ we want? With a syntax-line like mine ?
    It will offer more possibilities for Cam compatibility I think.

    Thanks for all

    JMarc

    #1194

    jerem
    Participant

    Hi JMarc !

    Thanks for troubleshooting this issue, just a little question, how did you configure de main stream in HD and the sub stream in MJPEG ?
    What model of cam are you using ?
    I’ll check my settings when I have more time pretty soon so stay tuned 😉

    #1302

    Coyote
    Member

    Hi Jerem,

    Sorry, I thought I have answered your post…

    I have a Foscam FI9805E, and you can convert the substream using a http command,
    Ask Google with ‘convertir flux secondaire’ and you’ll have a post about that.

    After that, you’ll find the http command line to see the stream in an Internet navigator.
    Yesterday, K.Rens have answered to a new topic, I’m asking him about the problem.

    JMarc

    #1305

    K.Rens
    Keymaster

    Hi,

    I found the page you are referring to in Google.
    I do get the result 0, but sadly the actual stream link does not work on my Foscam FI9816P.
    I get an empty response.

    Kind regards,
    K.Rens

    #1308

    Coyote
    Member

    Hi K.Rens,

    Have you try to put the http command line on an Internet navigator ? Just to confirm if it works ?

    I don’t know why and how, but now it works on my PS dashboard 🙂

    Here are my all parameters :

    camera.url :
    http://192.168.1.xx

    camera port :
    80xx

    camera.flux :
    /cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=XxxxxX&pwd=XxxxxX&t=

    Camera.name/pwd :
    nothing

    I don’t know if I have rebuilt the dashboard, or not… but I have the direct stream with my Foscam HD.

    If I can help you…

    JMarc

    #1309

    Coyote
    Member

    re Hi,

    In fact, I compile your http command with my command..

    If you don’t put the ‘&t=’ at the end of the command line, after the pwd, it doesn’t work on the dashboard…

    I hope that’ll work with your model 😉

    JMarc

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.