Configuring ZXT-120

Free domotica! Forums Protocol-specific Z-Wave (plus) Configuring ZXT-120

This topic contains 4 replies, has 3 voices, and was last updated by Mika Mika 2 years, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1337

    fred78350
    Participant

    Hi

    I successfully included my ZXT-120 devices to PulseStation, however no matter how much I try, I cannot change any configuration parameter => It’s like my device is read-only. The device is however not dead (ControllerState_NodeOK).

    My ZWave antenna is an Aeotec Z-Stick Gen 5

    Is there anything I did wrong?
    Thanks in advance for your help!
    Fred

    #1339

    fred78350
    Participant

    I have investigated the logs, and discovered that parameters are sent using 4 bytes although the ZXT-120 expects 2 bytes only, at least for parameter 27 which mentions the code to be used to command the AC.
    Some extracts:

    2015-10-03 16:54:03.790 Info, Node008, Sending (Send) message (Callback ID=0x25, Expected Reply=0x04) – ConfigurationCmd_Get (Node=8): 0x01, 0x0a, 0x00, 0x13, 0x08, 0x03, 0x70, 0x05, 0x1b, 0x25, 0x25, 0x83
    2015-10-03 16:54:03.799 Detail, Node008, Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
    2015-10-03 16:54:03.799 Detail, Node008, ZW_SEND_DATA delivered to Z-Wave stack
    2015-10-03 16:54:04.521 Info, mgr, Manager::WriteConfig completed for driver with home ID of 0xe7e3549c
    2015-10-03 16:54:07.384 Info, Node008, Value::Set – COMMAND_CLASS_CONFIGURATION – IR code number for built-in code library – 27 – 1 – 0
    2015-10-03 16:54:07.384 Info, Node008, Configuration::Set – Parameter=27, Value=0 Size=4
    2015-10-03 16:54:07.384 Detail, Node008, Queuing (Send) ConfigurationCmd_Set (Node=8): 0x01, 0x0f, 0x00, 0x13, 0x08, 0x08, 0x70, 0x04, 0x1b, 0x04, 0x00, 0x00, 0x00, 0x00, 0x25, 0x26, 0x8b
    2015-10-03 16:54:07.384 Detail, Node008, Queuing (Send) ConfigurationCmd_Get (Node=8): 0x01, 0x0a, 0x00, 0x13, 0x08, 0x03, 0x70, 0x05, 0x1b, 0x25, 0x27, 0x81
    2015-10-03 16:54:07.888 Detail, Node008, Received: 0x01, 0x07, 0x00, 0x13, 0x25, 0x01, 0x01, 0x99, 0x57
    2015-10-03 16:54:07.889 Detail, Node008, ZW_SEND_DATA Request with callback ID 0x25 received (expected 0x25)
    2015-10-03 16:54:07.889 Info, Node008, WARNING: ZW_SEND_DATA failed. No ACK received – device may be asleep.
    2015-10-03 16:54:07.889 Warning, Node008, WARNING: Device is not a sleeping node.
    2015-10-03 16:54:16.878 Info, Node008, Value::Set – COMMAND_CLASS_CONFIGURATION – IR code number for built-in code library – 27 – 1 – 4
    2015-10-03 16:54:16.878 Info, Node008, Configuration::Set – Parameter=27, Value=4 Size=4
    2015-10-03 16:54:16.878 Detail, Node008, Queuing (Send) ConfigurationCmd_Set (Node=8): 0x01, 0x0f, 0x00, 0x13, 0x08, 0x08, 0x70, 0x04, 0x1b, 0x04, 0x00, 0x00, 0x00, 0x04, 0x25, 0x28, 0x81
    2015-10-03 16:54:16.878 Detail, Node008, Queuing (Send) ConfigurationCmd_Get (Node=8): 0x01, 0x0a, 0x00, 0x13, 0x08, 0x03, 0x70, 0x05, 0x1b, 0x25, 0x29, 0x8f

    Other info:
    015-10-03 16:55:24.188 Detail, Node008, Refreshed Value: old value=0, new value=0, type=int32
    2015-10-03 16:55:24.189 Detail, Node008, Changes to this value are not verified

    Here, I guess this is why the ZWave controller sends 4 bytes instead of 2.

    Above in the logs, we can even read:

    2015-10-03 16:53:31.426 Info, Node008, Opening config param file /volume1/web/PulseStation/services/core/../zwave/config/remotec/zxt-120.xml
    2015-10-03 16:53:31.427 Info, Value list size is not set, assuming 4 bytes for node 8, class 0x40, instance 1, index 0

    Which file should I fix to specify that 2 bytes are required to set parameter 27?
    Thanks for your help!

    • This reply was modified 2 years, 1 month ago by  fred78350.
    • This reply was modified 2 years, 1 month ago by  fred78350. Reason: Highlights
    #1342

    K.Rens
    Keymaster

    Hi,

    Thank you very much for this detailed information.
    This will probably help Mika a lot in fixing the issue.

    We haven’t had a user yet using it, so will be good to investigate.

    Could you please also share the zwave.json file with us?
    It is located in the /volume1/web/PulseStation/data folder.

    Many thanks.

    Kind regards,
    K.Rens

    #1346

    fred78350
    Participant

    Sure, I’d love to. But file looks pretty big (~8K), and I don’t see any way to attach it here.
    And BTW, I got some positive results from my ZXT-120 devices while tweaking the /volume1/web/PulseStation/services/zwave/config/remotec/zxt-120.xml file: apparently, the file designed originally by the open-zwave team does not strictly comply with Remotec specs. The best matches I was able to find are from the openHAB project => see https://github.com/openhab/openhab/blob/master/bundles/binding/org.openhab.binding.zwave/database/remotec/zxt120.xml.

    Long story short, I replaced the “int” by “short”, which is 2 bytes long, and was successfully able to update the “27” parameter – although you need to be patient.

    HTH,
    Fred

    #1361
    Mika
    Mika
    Keymaster

    I think you found by yourself the solution.
    The config file for each devices are generated by openzwave.

    Maybe when there is a new release of the zwave service, dont forget to replace it again…

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.