DSM Version 6 + Pulsestation Problem

Free domotica! Forums Report a bug DSM Version 6 + Pulsestation Problem

This topic contains 39 replies, has 15 voices, and was last updated by  K.Rens 1 year, 5 months ago.

Viewing 15 posts - 1 through 15 (of 40 total)
  • Author
    Posts
  • #1547

    mate
    Participant

    Hi to all,

    Since the upgrade of my synology DS212+ to DSM 6 I am not able to start Pulsestation in the paquet center … Thes status is STOPPED and not possible to activate ….

    Has everybody the same problem and issue ?

    Christian

    #1550
    Mika
    Mika
    Keymaster

    I didnt have the time to investigate DSM6 but I suppose that it’s a problem of compilation.
    Maybe the toolchain has changed, I have to investigate that…

    Mika

    #1553

    coldbringer
    Participant

    Hey, I am having trouble also. The USB controller cannot be found, maybe they have renamed the USB ports? ttyACM0 is no longer correct. No results ttyS0 or ttyUSB0 either.

    [ 0.000000] Kernel command line: root=/dev/md0 rw syno_hw_version=DS213pv10 c onsole=ttyS0,115200 ip=off ihd_num=2 netif_num=1 ip=off initrd=0x2000040,4M
    [ 5.917048] serial8250.0: ttyS0 at MMIO 0xffe04500 (irq = 42) is a 16550A
    [ 5.923754] console [ttyS0] enabled, bootconsole disabled
    [ 5.934763] serial8250.0: ttyS1 at MMIO 0xffe04600 (irq = 42) is a 16550A
    [ 84.401299] cdc_acm 2-3:1.0: ttyACM0: USB ACM device

    #1554

    coldbringer
    Participant

    In my case it’s not DSM6 but DSM 5.2-5644, automatic update of last night.

    #1555

    RoyalTaz
    Participant

    Hello !

    Me too, i’ve “ERROR: Failed to open serial port /dev/ttyACM0” on my DS110+ with 5.2-5644
    I’ve removed PulseStation then reinstaller it, but no change.

    #1556

    Dave
    Participant

    Hallo,
    have you tried to connect via SSH using Putty (as described herein: https://www.pulse-station.com/frequently-asked-questions/ under “How do I know my USB key is detected”) to get the right setup?

    #1557

    coldbringer
    Participant

    yup, i have posted my putty output above. looks like it should still be ttyACM0 (in theory)

    #1558

    RoyalTaz
    Participant

    Me too, i’ve the same things :
    [ 1.350389] serial8250.0: ttyS1 at MMIO 0xe0004600 (irq = 42) is a 16550A
    [ 26.708953] cdc_acm 1-1:1.0: ttyACM0: USB ACM device
    [ 306.184200] cdc_acm 1-1:1.0: ttyACM0: USB ACM device

    #1563

    coldbringer
    Participant

    I have searched the Synology forums and found a guy who develops special USB drivers for Z-Wave sticks on Synology NAS systems. He even mentioned the support of the latest DSM version 5.2-5644. So now I am pretty sure it is a driver-related issue. Obviously, there is currently another issue that USB 3.0 harddisks on the USB 3.0 port work at USB 2.0 speed only.

    I have installed the driver package but it didn’t help. Maybe you want to try it yourselves:

    http://www.jadahl.com/drivers.html

    #1570

    RoyalTaz
    Participant

    Hello !

    Mika have made an upgrade !

    It’s the 1.2.2.
    So, upgrade, reboot the Syno…and run 😉

    Rgds

    #1572

    K.Rens
    Keymaster

    Hi, latest news:

    1) Update DSM 5.2-5644
    This one works with PulseStation.
    If in the logs of Z-wave after the update you see “Error code 13”, you will have to grant access rights to the usb key again for PulseStation.
    Execute following commands via ssh:
    chmod 777 /dev/ttyACM0
    chmod 777 /dev/ttyUSB0

    2) DSM 6.0
    There is no toolchain available yet to build the new drivers.
    Once it’s available we can build compatible drivers.
    So please wait a bit before installing it, just to be certain.

    Kind regards,
    K.Rens

    #1606

    dartagnan
    Participant

    Hi
    with DSM 6.0 Beta, I can’t add the repository, an error occurs : La connexion a echoué
    if i remove the pulse repo the problem no longer occurs

    Thanks

    #1972
    Mika
    Mika
    Keymaster

    Hi All,

    Looking for someone who is on DSM 6.
    Have the necessary stuff to start it!

    Will start in the coming days…
    I eventually need access to the NAS (ssh, folder ./web/PulseStation file filestation) to debug it…

    If someone is interested, feel free to contact me!

    Mika.

    #2667

    121an193
    Participant

    Hi,

    Still looking for someone on DSM 6 (beta 2) ?

    Laurent

    Dieu est mort, Marx est mort et moi-même, je ne me sens pas très bien... (Woody Allen)

    #2672

    K.Rens
    Keymaster

    Yes, we are still looking for people on DSM 6 for helping us test whether our software works or not.
    We can build a custom package for you if you are willing to help us, all we need to know is your NAS model.

    Kind regards,
    K.Rens

Viewing 15 posts - 1 through 15 (of 40 total)

You must be logged in to reply to this topic.