Graphics – Unable to connect to the database

Free domotica! Forums How can I …? Synology NAS Graphics – Unable to connect to the database

This topic contains 4 replies, has 4 voices, and was last updated by  K.Rens 11 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3732

    dexton03
    Participant

    Hello,

    I have just installed PulseStation on my Synology 1513+ DSM6. I am walking through setting it up and can not figure out how to get the graphics to work on it. I have followed the steps in the FAQ, but that doesnt seem to have worked. I believe that is my one issue as of right now, I have been reading the forums for setup and deployment.

    Thanks!

    Dex

    #3733

    dexton03
    Participant

    Ok, I got it to connect to the database, but there is nothing in the database and when I click on graphics, it just stays on “loading database’s data…”

    #3949

    200kmh
    Participant

    I have the same problem.

    Tried to fix it with this two lines but it didn`t fix the problem:
    sudo mv /usr/bin/php /usr/bin/phpORIG
    sudo ln -s /volume1/@appstore/PHP5.6/usr/local/bin/php56 /usr/local/bin/php

    I still have “loading database’s data…” when i want to load “Graphics”.

    Why

    #3950

    Juan Miguel ORTIZ
    Participant

    Hi,
    I have the same problem also.
    everything seems to be up and running but database has not been created properly. it seems to be empty.
    I’ve tried to re-install but same problem.
    I already run:
    sudo mv /usr/bin/php /usr/bin/phpORIG
    sudo ln -s /volume1/@appstore/PHP5.6/usr/local/bin/php56 /usr/local/bin/php

    #3951

    K.Rens
    Keymaster

    If you run in ssh following command:
    php -m

    You should see mysql inside this list.
    If mysql is not in the list, then:
    – Either you have not installed and activated MariaDB
    – You have not activated mysql in the webstation settings

    If you do see mysql in the list with following command:
    php56 -m

    Then the command I mentioned in the faq (the sudo mv and sudo ln commands), will fix it.
    If both php versions do not have mysql, then we do have an issue.

    Sadly Synology is terrible in having different versions of configurations between different devices, that’s why personally I switched to a raspberry pi 3 😉

    Inside webstation I am using “apache” and php5.6 as setting.
    If it’s nginx, it may also not work.
    If that’s the case, contact me in the live chat so I can see whether I can get it to work for your setup as well.

    Kind regards,
    K.Rens

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.