Impossible to identify Id Product

Free domotica! Forums How can I …? Synology NAS Impossible to identify Id Product

This topic contains 3 replies, has 2 voices, and was last updated by  LoJaume 1 year, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #3463

    LoJaume
    Participant

    After hours trying to include/exclude devices, instal/uninstall PS, stop/start services, and actions like that -including some desperate whisky drinks- I haven’t succeed on installing a Fibaro FGRM222 roller-shutter.

    When I include this device, I get “Unknown: type=0302, id=1000” in roller-shutter Product property.
    Also, I get a “Unknown: type=0001, id=005a” Product property in Aegon Gen5 USB device

    Yes, I saw it is necessary to add this line in manufacturer_specific.xml file:
    <Product type=”0302” id=”1000” name=”FGRM222 Roller Shutter Controller 2″ config=”fibaro/fgrm222.xml”/>
    I did it before including devices.

    Any other idea before I empty the whisky bottle?

    Two months ago, I succeed on running two fgrm222 roller-shutter, but a new PS version damaged all and I abandoned this project. Now, it seems more difficult to start it again.

    #3464
    Miss Laura
    Miss Laura
    Moderator

    Hi,

    1) You can try adding:
    https://github.com/OpenZWave/open-zwave/blob/master/config/fibaro/fgr222.xml
    2) Then add a line to manufacturer_specific.xml
    3) Clear the zwave config files from within the zwave administration panel.

    It should then become a known device.

    Have fun,
    Laura

    #3466

    LoJaume
    Participant

    Thanks, Laura

    1) ok, “fgr222.xml” file added in …services/zwave/config/fibaro folder

    2) which line?
    I had already put this line:
    <Product type=”0302” id=”1000” name=”FGRM222 Roller Shutter Controller 2″ config=”fibaro/fgrm222.xml”/>

    Should I change something?

    3) “clear config files” (blue button) seems to do nothing

    :o/

    EDIT: I tried fgr222.xml instead of fgrm222.xml and it’s the same: Product unknown.

    • This reply was modified 1 year, 1 month ago by  LoJaume.
    #3468

    LoJaume
    Participant

    Well, in fact, it works as a switch: true/false, changing switch property.

    The problem is PS hasn’t identified the device

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.