Issue with scenes + zwave

Free domotica! Forums How can I …? Synology NAS Issue with scenes + zwave

This topic contains 16 replies, has 3 voices, and was last updated by  macgreg0r 1 year, 7 months ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #2188

    macgreg0r
    Participant

    I’m trying to create a simple scene with blocky to control my zwaves devices.
    meanwhile my devices are correctly controled under dashboard, I have 2 issues:
    1- dashboard display is wrong, it showing a device “On” while it’s “Off” and vice versa. When I switch state the dashboard is switching but after 5 or 10 seconds it goes back to previous display state, but the device state does not change.
    2- In Blocky scenes my devices are not controled, even with the simplest scene with just zwave device command, the device do no change state.

    I’ve restarted all services, an even pulsestation, updated all modules, but nothing is changing.
    Does anyone experience such issue and have a clue for resolution?

    #2214
    Mika
    Mika
    Keymaster

    Did you already try to exlude and the reinclude your device to your controller ?

    #2222

    K.Rens
    Keymaster

    Also make certain the device is not too far from your usb key while testing.
    It may be range related.

    Kind regards,
    K.Rens

    #2316

    macgreg0r
    Participant

    Hello,

    Thanks for your answers.
    Yes I allready exclude a reinclude my devices. And my devices are working well with the dashbord commands, there is only a few meters with he devices.
    One other thing is that when I activate the scene service, one of my device is always shuting down.
    I put it on through dashboard or device button, then after few seconds (1minute max) it goes off.
    When I was using synozwave all worked fine, except dashboard refresh about devices state.
    I once installed Domoticz with Zwave support and I had this behaviour too.
    I can’t figure what in my system is doing that.

    #2317

    K.Rens
    Keymaster

    Since the device turns off when you activate the scene service, I would assume one of your scenes is telling the device to turn off.
    It should otherwise not do it.

    Can you also check whether the device that is turned off is not associated to another device?
    Maybe something is supposed to turn of, but since the devices are associated (coupled), it also turns of the other device.

    If that doesn’t resolve it, we will have to look on your system what could be the cause.

    Kind regards,
    K.Rens

    #2328

    macgreg0r
    Participant

    I have tried with no scene at all and my device still goes off.
    I got only 3 zwave devices on my system: 2 Fibaro wallplugs and one Aeon labs Zwave stick.
    I don’t remember that I ever coupled device.
    Maybe I have some old files from previous install, scenes on my system…

    #2337
    Mika
    Mika
    Keymaster

    First, If you said that you have the same behaviour with Domoticz, it probably means that it’s something with OpenZwave and the configuration of your device.

    Did you already try to reset your wallplugs ?
    Do you see in the association tab that your wallplugs are only associated to your controller (zwave-1)

    #2345

    macgreg0r
    Participant

    I’ve reseted my entire system last month by desassociate my plugs and then reassociate them.
    In the association tab I have only zwave-1 (which is my aeon stick) at the botom of the page, with a “delete association” option.
    I have nothing in groups 1 and 2.

    #2346

    K.Rens
    Keymaster

    Hi,

    I think I will have a look on your system.
    Can you mail us (to the store mail adress) credentials to ps, url and precise explanation what is wrong at which step and what happens / should happen?

    Thank you,
    Koen

    Kind regards,
    K.Rens

    #2540

    macgreg0r
    Participant

    Hello again,

    With the help of Mika and Koen it works for 2 days :D.
    but now scene does not work anymore. No logs at all.
    I’ve restarted scene service, change scene period, then reinstall it, then reboot DS, and nothing work, scene service still have no logs.
    Is there a sort of cron? where can I look for a clue?

    #2572

    K.Rens
    Keymaster

    And if you start the scene service from the command line?
    Just put autorestart on no, stop the scene service and start it from the terminal?

    Kind regards,
    K.Rens

    #2608

    macgreg0r
    Participant

    Sure I can try,
    how do I do that? Is it a curl command or something like that to launch?

    #2625

    K.Rens
    Keymaster

    Instructions are here:
    https://www.pulse-station.com/faqs/debugging-the-core-and-all-services/

    Basically you need to enable ssh and connect to your server in command line mode.

    Kind regards,
    K.Rens

    #2689

    macgreg0r
    Participant

    I don’t know why but the service worked the 1st of february for 00H00m to 18H18m and since then nothing.
    I have been in /volume1/web/PulseStation/services/scene and launch ./scene, here is the result:
    ExoNAS2> ./scene
    2016-02-09 14:14:48.253 Starting service scene at port : 4040
    ps: invalid option — ‘a’
    BusyBox v1.16.1 (2015-10-28 13:16:35 CST) multi-call binary.

    Usage: ps

    Report process status

    Options:
    w Wide output

    every minute I get this Ps error.

    #2690

    macgreg0r
    Participant

    I’ve desinstalled all and reinstall all again.
    now I can’t even add a zwave controler to the dashboard…
    I’m trying to reinstall again…

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.