Make a 'fast' bocky rule

Free domotica! Forums How can I …? Synology NAS Make a 'fast' bocky rule

This topic contains 20 replies, has 5 voices, and was last updated by  Arti 1 year, 8 months ago.

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #1226

    Coyote
    Member

    Hi everybody,

    I just try to make rules with blocky… And I have a question..
    I plug a fibaro motion sensor, and a swiidinter switch.. I just want to turn on automatically my lamp when a motion is detected by the sensor..

    My rule is oki, my light is turning on and off, but my problem is the latency of my rule…..
    When my lamp is switching on, I’m far.. far… away !!!

    I try to modify the scene service time (1 minute by default).. but I can’t put less than 1 minute..

    Any ideas ?

    Thx

    JMarc

    #1227

    K.Rens
    Keymaster

    Hi JMarc,

    I had the same issue in the beginning.
    The distance between the usb key and the swiidinter was too long and I had not enough devices in between to relay the message to it.
    It all got a lot faster after I purchased more hardware and added them.

    You can try:
    – add more hardware
    – add a repeater (it’s not listed in the store, but I can sell it at discount if you want)
    – reduce the distance between the controller (usb key) and the swiid.

    Note:
    Maybe first try rebuilding your z-wave network.
    Under services open zwave, click on the button “Controller commands” and then press “Clear config files”.
    It will then rebuild your network, trying to use all devices in it’s network.
    Wait 15 minutes at least till every z-wave device is scanned and the network is built.

    Then try it again.
    This worked for me as well. I do this sometimes after I get new hardware 😉

    Kind regards,
    K.Rens

    Kind regards,
    K.Rens

    #1234

    Coyote
    Member

    Hi K.Rens,

    Thanks for your informations.
    Some questions about that :

    You’re right, my Zwave mesh is a bit wide.. I have plugs and repeater.

    I already try to reset my config, but it only finds nodes that it finds on the first association.. It seems that there is never a new mesh in the log file (Always the same node’s neighbors).

    I need to be closed to the usb Zwave adaptator to associate my differents Zwave products, and after that, I put them in my home, and do a reset config. It always keep old network, never new associations… And after that, some nodes are ‘dead’..Anyway.. I don’t know if I have all understood 😉

    Just to talk about blocky. If it refreshes rules only one time by minute, my swiid switch can’t have the message before this delay (one minute minimum) no ? Between this lap, the order is in the queue I thing…
    For example, if my sensor is ‘true’ at 9:40:15 PM, the order is only sent at 9:41:00 PM, 45 seconds after no ?And sometime my sensor goes back to ‘false’ before the blocky scene order…(And of course.. the network latency after all that)..
    Is it possible to refresh more quickly ? To avoid to wait this minute ??

    I continue to work on this !!

    Thanks

    JMarc

    #1236

    K.Rens
    Keymaster

    Hi,

    This is the blocky rule I use in order to turn on the lights in the kitchen once motion is detected and it is instant.
    No need to wait for the next minute.

    http://screencast.com/t/DgV5ZpiMG

    You need to use the device event block, then it’s instant.

    Kind regards,
    K.Rens

    #1304

    Coyote
    Member

    Hi K.Rens

    Very good ! I didn’t understand the ‘Device Event ==’ block.

    Now it works fine, only few seconds before turning on my lights…

    Thanks a lot ;-))

    JMarc

    #2084

    coldbringer
    Participant

    Any idea, why this rule doesnt do anything?

    Unbenannt4

    Motion Sensor works, PushOver service works as well.

    Thanks

    • This reply was modified 1 year, 9 months ago by  coldbringer.
    • This reply was modified 1 year, 9 months ago by  coldbringer.
    #2089

    K.Rens
    Keymaster

    Can you put an “add log” block, with some text before and some text after the pushover message?
    This will allow you to see in the logs whether:
    1) it actually goes into the if
    2) whether it does go all the way till the end

    Alternatively you can try starting the core via ssh (see faq) and see what is written to the core one you do the actual move.

    Note:
    the device event is only sent on the first movement.
    If you keep on moving afterwards (value remains true), it will not send a new device event.

    Kind regards,
    K.Rens

    #2091

    Coyote
    Member

    Hi Coldbringer,

    I have the same issue for 2 weeks.. You can see my post ‘Blocky doesn’t run my scene’.

    There is no events in the log scene with “Device Event”… It doesn’t work anymore..

    Mika told me to wait a new release soon…

    JMarc

    #2104
    Mika
    Mika
    Keymaster

    If it’s the same issue as Coyote, I didnt see the zwave service triggering the event.

    I’m just wondering if it’s not linked with the association…

    Coldbringer, now that you have access to the beta release, can you check in the association tab if you see your controller ?

    #2259

    Coyote
    Member

    Hi all,

    I’ve done some new tests with the 1.3.0 version of PS, but I still have the same issue… We can’t have a device event.
    All is oki in the ZWave log (good assosciation, good neighbors), all is oki in the dashboard (detection is also ok with imperihome), but It can’t launch scenes.

    Nothing to do..
    I have tried with another Fibaro eye sensor, and I have the same issue.
    If I put another sensor like the Fibaro door sensor, it’s the same issue too.

    Help please !! :-)))))

    JMarc

    #2260

    K.Rens
    Keymaster

    If you go to services/zwave/you edit your motion sensor/ you click on the associations tab,
    do you then see at the top association zwave-1?

    You never answered Mika’s last question.
    For me this solved the issue.

    Kind regards,
    K.Rens

    #2264

    Coyote
    Member

    Hi K.Rens
    Sorry not to have answered to this question.
    In the association tab, to the 《Device Status (COMMAND_CLASS_ASSOCIATION)》I can find my Zwave Stick [Zwave-1].

    As I said before, all seems oki….in the log…on the dashboard. ..there is just the Device event that doesn’t work….

    Jmarc

    #2266

    K.Rens
    Keymaster

    Your usb key should be listed twice.
    This is how the associations look for me:

    Basic Report (COMMAND_CLASS_ASSOCIATION)
    zwave-1 Remove Association
    Tamper Alarm (COMMAND_CLASS_ASSOCIATION)
    Device Status (COMMAND_CLASS_ASSOCIATION)
    zwave-1 Remove Association

    Kind regards,
    K.Rens

    #2270

    Coyote
    Member

    Hi,

    I’ve added ZWave-1 association in the Basic Report, but there is no improvement.
    All is oki for the detection, only the “Device Event” that still not working..

    PS : I’m using Aeotec Gen 5 USB Stick.. But I’ve not changed my hardware config.

    Other ideas ?

    Thank you 😉

    JMarc

    #2273

    K.Rens
    Keymaster

    Did you stop all services and restarted core and zwave after the association is done?
    It could take up to 24 hours (unless if you manually wake up the motion sensor) before it takes the update.

    In the next release of PulseStation you can see the queue of the pending commands to be sent to sleeping device.
    It will give you better visibility on whether it’s done or not.

    Kind regards,
    K.Rens

Viewing 15 posts - 1 through 15 (of 21 total)

You must be logged in to reply to this topic.