[Support request] Multiple Issues scenes/blocky/graph

Free domotica! Forums Report a bug Multiple Issues scenes/blocky/graph

This topic contains 4 replies, has 2 voices, and was last updated by  macgreg0r 10 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3713

    macgreg0r
    Participant

    Hello,

    I again have issue with scenes:

    1) I tried to modify some scenes, but some scenes are blank in blocky, they only have “run scene manualy”, php view is empty, xml view is working.
    I can launch those blank scenes manualy (with dashboard or imperihome service) and those are executed.
    2) I have although otehr scene with “time = XX:YY” that are not running, but are correctly diplayed by blocky.
    I noticed that in scene logs, the time is not correct it is my time + 6 hours… ? => I try to restart and even reinstall scene service, but it’s the same.

    3) I have a fibaro smoke sensor with T° value. I add this value to Dashbord with no problem. but I tried to make a graph with this value, and I can’t see my sensor in Device list.
    Moreover, Imperihome see the sensor but only as a smoke sensor and does not have acces to T° value.

    #3714

    K.Rens
    Keymaster

    1) Empty scenes solution:

    2) If you are on raspberyy pi you may need to set the correct timezone there for your user.

    3) I’m currently working on an update of the zwave library.
    After that is done, I can start on looking at imperihome and what we send to it.
    You could check inside the advanced imperihome service settings, but if the smoke is there, then it’s just things I need to change in the imperihome code.

    Kind regards,
    K.Rens

    #3719

    macgreg0r
    Participant

    Hello,

    Thanks, I’ve removed a vdevice recently and it was on my scenes, but I forgot about it…
    Now i’ve corrected all scenes and template. one good point.

    I’m on Synology latest DSM a latest patch level. Core logs time are OK, only scene time logs are wrong…
    Scene that are not working are using time based trigger and/or weekend/weekday templates.
    I noticed that Yweather file: “yweather.json” is no more updated since weeks (17 july 4PM to be precise). can this be linked too?

    #3721

    macgreg0r
    Participant

    I think, I’ve found why logs for scene are wrong.
    I wrote a little php that is echoing date:
    <?php
    $dateTime = new DateTime();
    echo $dateTime->format(‘Y-m-d H:i:s’)
    ?>
    then executed it:
    /usr/local/bin/php t.php
    2016-09-14 11:30:20
    php t.php
    2016-09-14 17:29:51
    I saw that again my “/usr/bin/php” is no more “/usr/bin/phpORIG”
    I’ve done the “sudo mv /usr/bin/php /usr/bin/phpORIG” again and the result is that php is now giving good date. I hope that now that I’m using the good php verison scene and other things will work again, I’ll keep you informed.

    I think it’s the 4th time I rename it…Can you tell me what is going on? is it synology updates that are changing it?

    #3722

    macgreg0r
    Participant

    News:
    now time based scenes are working correctly!

    Just need to correct yweather that is no more updating since July…no clue about what is going on…

    Edit: I can’t delete yweather device ether.

    • This reply was modified 10 months, 2 weeks ago by  macgreg0r.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.