Ping on vDevice

Free domotica! Forums How can I …? Synology NAS Ping on vDevice

Tagged: ,

This topic contains 4 replies, has 4 voices, and was last updated by  mehlhold 2 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1737

    MrMorgan
    Participant

    Hi,

    I want to know how can I start a Ping on a vDevice?

    At first: I have create a vDevice (Ping) and give it the IP-Address “192.168.0.X”.
    Second: At the the Blockly Board, I added a new scene with the command –>

    If vDevice “Ping” Status = True
    Do vDevice “PC Status” = True/On
    Else vDevice “PC Status” = False/Off

    My scene jumped directly to Else. I guess that the Ping command not realy started.
    In the seetings of the virtual Device I have found an entry of Ping Status (False).
    Now I’m not sure if the entry in the settings the default status or the current updated status.

    Thanks for your help and apologize my bad english 🙂

    #1741

    mehlhold
    Participant

    Virtual Ping = No recognition

    Hello there,

    Virtual Ping only recognizes my Fritzbox 192.168.178.1 via LAN

    No recognition of my Android phone 192.168.178.27 WLAN

    No recognition of my Ubuntu PC 192.168.178.21 via LAN

    Why can I enter a port?

    #1749
    Mika
    Mika
    Keymaster

    You have to find an open port on your android devices. (maybe there are app to open port).
    Once you have that, you have a property “ping.port”.

    For example, on my iphone i use the port “62078”. Once i unlock my iphone, PulseStation knows that I’m in.

    Mika

    #1759

    K.Rens
    Keymaster

    On Synology you cannot access the “real” ping command.
    That’s why we need to bypass it and add a port.

    This also means you have to find an open port on your device.

    For Android you can use following app to find “LISTEN” ports, ports on which your device is listening:
    https://play.google.com/store/apps/details?id=com.eolwral.osmonitor
    The second tab tells you all the open ports.

    I found out you can use for instance the skype port, if you have it installed.
    The Facebook Messenger port however does not work.

    In the end I installed a webserver on my phone that is always listening on port 12345.
    https://play.google.com/store/apps/details?id=jp.ubi.common.http.server
    NOTE: inside the settings you have to enable the authentication and set up a strong password.
    Otherwise users can access the content of your device.
    I also recommend to make it start automatically with your device.

    So now you can always see whether your device is enabled, or that you are at home if you set it up on your phone.

    Kind regards,
    K.Rens

    #1777

    mehlhold
    Participant

    Many thanks.
    I’ve tried with the listening port the OS Monitor has shown me (K9, Google sevices, DSCloud, FritzApp ect. Unfortunately, without success.
    I do not like Facebook and Skype.

    I have now set up a web server on server Ultimate and with Tasker I turn it on/off when I’m connected to my Wi-Fi.

    It works.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.