Port-porblems to connect synology and impery home

Free domotica! Forums How can I …? Synology NAS Port-porblems to connect synology and impery home

This topic contains 5 replies, has 3 voices, and was last updated by  K.Rens 1 year, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #863

    Superperle
    Participant

    Hi, just startet using z-wave plug on synology. I only managed so far to.create working if, than else, blocky things….

    I don’t get, how to manually posh a.button to turn on light right now and turn it off when wanted.
    So I tried to run imperi home app…but I can’t connect to port 4070 as stated in FAQ.

    Is th port needed in thefirewall of synology, in the router of my local network…. I have No clue, how these things work. So please for dummies.

    With telnet I manage to connect to port 5000 no problems. But I can’t open 4070. Can I use different one…which one?

    Help would be nice… Videos of some blocky rules setups would also.Be nice.

    Thanks for the help.

    #864
    Mika
    Mika
    Keymaster

    Hi,

    It seems that you have multiple problems.

    1/ What do you want to do exactly with blockly ?

    2/ For Imperihome, if you want to use it remotely you have to open the ports on your NAS and/or your router depending what you want. If you use it locally normally just follow the procedure on the website and it should works.

    Note : I’m just thinking about reworking Blockly to be more simple…

    Regards,
    Mikael

    #900

    Superperle
    Participant

    Hi,

    thanks for your reply!

    I guess that I have multiple problems 🙂 I just try to solve each one seperately.

    Blocky worked yesterday….. If time ist between 22:00 and 23:00 turn on the light….. Worked! Happy

    I dont get it, how I can switch the light, in an elegant manner like over the Phone or one clik on the laptop on and off outside of the blocky rule…..

    So my try was to use the app stated in den FAQ of Pulsestation…

    Now my problem is that I can´t connect the app to the NAS…. Po 4070 does not work. I want to use the phoneonly in my personal Wifi. No connekton over the web needen. So I dont want to turn the light on/off while at work only at home

    Ich have very lillte knowalge of networkstuff….. so I tried:

    TCP Portforwading in den Wirelessrouter TCP to the IP:Adress of the NAS wir the PORT 4070….

    In addition I thought I opened all connections in the NAS in the Firewall…. as the sole opening of the port 4070 in the Synology-Firewall also did not make any difference.

    Now I am lost…

    I Tried tocheck the connections and the reachability of the Ports using the windows- tool “telnet” in the commandline. I can reach fo example port 5000 (standart to reacht the userinterface of DSM 5.2) but I can never connect to 4070…

    Can I use a different Port, that is allready there in the NAS BOX, so that Ih dont have to open an totally new one?

    Any one of Those?

    https://www.synology.com/en-us/knowledgebase/faq/299

    Best reguards

    Stefan from Germany

    #901

    K.Rens
    Keymaster

    Hi,

    If you open the url with port directly on your computer, are you able to see some information?

    If I visit following url:
    http://192.168.1.2:4070/
    I get:
    {“id” : “My Service”, “apiversion” : 1}

    If you don’t get this, there are several options:
    1) Verify the imperihome service is running under the services panel inside the administration.
    2) Verify in the synology firewall that you fully allow port 4070.
    3) If it then still does not work, it’s your router that is blocking this port.
    You could try adding the ip of the nas to the DMZ (note: it will be accessible from outside of your network) or open up the port in the router settings.

    If all this does not work, I could make a remote connection with your computer and try to sort it out step by step.

    Kind regards,
    K.Rens

    #986

    Superperle
    Participant

    I finally managed to solve the Problem!

    I overread somthin ind FAQ…. Maybe one can write that more clearly in the FAQ, that not only I have that problem
    Mainly my prblem was th identify where in wich program to do what….

    Problem 1…. in old text 1:
    The administration panel inside the program Pulse-Station ist ment!!! I did not install this Plugin….. That was my problem, why it did not run!!!!!!
    I found that yesterday! Nobody was listening on port 4070….. so there was naturally nothing answering the calls!

    Room for missinterpretation is talso in point 4 of the discription.

    Firewalls are im my place usually in the router…. Here the firewall of my NAS-Box synology was ment!!!! So I was alwasy looking in the router and not the NAS-BOX. Maybe we can add this to the description… Sure one also (in addition) hase to open a port in the router, if he/she wants to connect over the internet…..Than open two ports…

    Its also not stated, that the port to be opend should be a TCP port… in my router also an other option was stated and I did not know which option to chose…

    I am a Computerdummy so I need highly specific rules… or a video could be nice…
    now it works. Now Ih have to overcome tne next problem… correct blocky rules…

    Old Text:
    1) Inside the administration panel, go to the store and install the Imperihome service.

    2) Once it’s installed, install the Imperihome app.
    There is a free version of the app available in Google Play store.
    Note: the Imperihome iOS app will be launched in the coming weeks. It’s currently being tested.

    3) Go to settings inside the app, open “My systems”, tap on “Add a new system”, choose for the “Imperihome Standard System”.
    Fill in following url: http://IP:4070 (replace IP with the IP of your PulseStation server).
    Also provide the login and password from PulseStation.

    4) Press next and verify the system was detected. If not: open port 4070 in your firewall (needed on Synology for instance).

    Many THANKS for the SUPPORT!!!!! You were very quick to answer… very nice

    Stefan

    #988

    K.Rens
    Keymaster

    Thank you for the great feedback, I updated the faq.

    “1) Inside the PulseStation administration panel, go to the store and install the Imperihome service.”
    And added TCP on line 4.

    Kind regards,
    K.Rens

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.