[Support request] Problème de fonctionnement de blockly

Free domotica! Forums Report a bug Problème de fonctionnement de blockly

This topic contains 17 replies, has 5 voices, and was last updated by  francois.jolivet@yahoo.fr 1 year, 5 months ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #4161

    • Dans la log de Scene Service
    « Periodic : Start » se suivent mais jamais de « Periodic : End »

    • Les scènes développées en blockly ne s’exécutent pas

    o Solution de contournement temporaire
     Suppression de « Globalscene.php » dans le répertoire DATA/Scene
     Arrêt de tous les services y compris « Core Service »
     Relance des services avec « Core Service »
    o RESULTAT : les scènes s’exécutent correctement ; mais à la prochaine relance de DSM il faut reprendre cette solution de contournement.

    Cordialement

    #4163

    K.Rens
    Keymaster

    Hi,

    Can you send me your globalscene.php file after it’s broken and again after it’s fixed?
    I would like to see what’s the difference between the 2 files.

    So far, when there is no “end” appearing, usually one of the scenes became corrupt.
    Never seen this issue before otherwise, but did get 1 other complaint like this, this week.
    So I need to investigate.

    Kind regards,
    K.Rens

    #4173

    djandib
    Participant

    I had this last week after I had to install pulse-station from the beginning.
    But I forgot to copy my existing variables in the new version.

    So if you work with persistent variables, check if they are really available.
    e.g.:
    php-blocky: $test = file_get_contents(‘test’, FILE_USE_INCLUDE_PATH);
    Check if there is really a file “test” in the root-directory or in “Pulsestation/utils/PHP”.
    In my case it helped.

    Andi

    #4229

    macgreg0r
    Participant

    Hello,

    I think I have the same issue since friday 31th march (before upgrade to DSM6.1 and USB driver upgrade of this WE).
    My time based blocky scripts are no more running.
    But manual run scene are working.
    I didn’t do any change last week on my config…
    If I check scene logs I have no “Periodic: End” into it, only “starts” like François.
    My DSM update and reboot did not solve the issue.
    I tried to rewrite some scene, but it’s not running. but if run it manualy it works.

    #4231

    K.Rens
    Keymaster

    Aha, your php is broken again.

    In that case go to ssh and execute the commends to fix them.
    It’s at the bottom of the synology installation page (dsm 6 fix).

    Normally these are the commands:
    sudo mv /usr/bin/php /usr/bin/phpORIG
    sudo ln -s /usr/local/bin/php56 /usr/bin/php

    Kind regards,
    K.Rens

    #4232

    macgreg0r
    Participant

    I don’t think php was gone again, because “run manualy” scene were working alright. that’s not the case when php56 link is missing.

    Like I said I’ve upgraded to DMS6.1 this WE and after solving USB drivers issues and restoring php56 link, the scene issue was still there.
    I manadged solve it by:
    -stoping scene
    -uninstalling it
    -backup scenes in an other directory
    -removing all in scene directory
    -reinstalling scene service
    I then created a new test scene, and logs were OK with “start” and “end”.
    I then imported each of my scene from backup, and each time check logs.
    At then end all my scenes are back to work and logs showing “start” and “stop”.
    I can’t figure out what happend…

    #4358

    macgreg0r
    Participant

    the scene issue is back, here are scene logs:
    2017-04-13 08:58:01 Periodic : Start
    2017-04-13 08:58:02 Periodic : Scene “ma scene.php” deactivate
    2017-04-13 08:58:03 Periodic : End
    2017-04-13 08:59:01 Periodic : Start
    2017-04-13 08:59:02 Periodic : Scene “ma scene.php” deactivate
    2017-04-13 08:59:03 Periodic : End
    2017-04-13 09:00:01 Periodic : Start
    2017-04-13 09:01:00 Periodic : Start
    2017-04-13 09:02:00 Periodic : Start
    2017-04-13 09:03:00 Periodic : Start
    2017-04-13 09:04:00 Periodic : Start

    Stopping scene service and restart it does not solve the issue.
    I check core log at that hour and nothing abnormal, just ywheather update.

    I then checked php:
    $ sudo ls /usr/bin/php
    ls: cannot access /usr/bin/php: No such file or directory
    $ sudo ls /usr/bin/php*
    /usr/bin/phpORIG

    My php link was gone!! how can that happen? I didn’t do it. I have no auto-update. Does a package update can do that? but I don’t remember to has updated a package a 9AM…
    I’ve restored the link and then restarted scene service, but no luck the log are showing again no stop.
    I checked in scene directory and found out that globalscene.php was writen at “Apr 13 08:59”
    Just before scene log showing only “starts”.
    here is the content of the file:
    <?php
    if(file_exists(dirname(__FILE__).DIRECTORY_SEPARATOR.”prescene.php”)){include(dirname(__FILE__).DIRECTORY_SEPARATOR.”prescene.php”);}
    include(“/volume1/web/PulseStation/services/scene/../../data/scenes/XXXXX.php”);
    include(“/volume1/web/PulseStation/services/scene/../../data/scenes/YYYYYY.php”);
    include(“/volume1/web/PulseStation/services/scene/../../data/scenes/FFFFFFF.php”);
    include(“/volume1/web/PulseStation/services/scene/../../data/scenes/GGGGGGG.php”);

    Does it seems corrupted (I only changed scenes names)?

    Edit: After many tries and no “stops” in scene logs, I finaly stop all services zen restart, and scene service is now running Ok again…I gess that if php link is disable, we have to restart Core service after restoring it.

    • This reply was modified 1 year, 7 months ago by  macgreg0r.
    #4361
    Miss Laura
    Miss Laura
    Moderator

    Yes, when you change php, you have to restart the core.

    The best way to verify your php installation is to run the health check service.
    Or execute in ssh:
    php -m
    and verify that mysql is there.

    Have fun,
    Laura

    #4364

    djandib
    Participant

    Hi all there,
    I have the same error since 1 day. (19th). I just noticed it, because y variables aren`t written anymore…
    I`m still playing with stop Scene Service and reinstall and so on…
    Has someone an explanation WHY this happened (MCGregor an me almost the same day…) and finaly the right way to solve the Problem?

    Andi

    #4366
    Miss Laura
    Miss Laura
    Moderator

    – Did you update Synology recently?
    – What was the outcome of the health check service? Did it find mysql?
    – What do you get when you execute php -m via ssh?

    Have fun,
    Laura

    #4367

    djandib
    Participant

    – No Update Synology recently
    – HealtchCheck: Everything alright with MySQL
    – I get:
    [PHP Modules]

    mysql
    mysqli
    mysqlnd

    Seem all there, BUT:

    $ sudo ls /usr/bin/php
    ls: cannot access /usr/bin/php: No such file or directory
    $ sudo ls /usr/bin/php*
    /usr/bin/phpORIG

    ????
    Scene Log:
    2017-04-21 18:24:05 Periodic : Start
    2017-04-21 18:25:07 Periodic : Start
    2017-04-21 18:26:09 Periodic : Start
    2017-04-21 18:26:33 Periodic : End
    2017-04-21 18:27:10 Periodic : Start
    2017-04-21 18:28:10 Periodic : Start
    2017-04-21 18:28:12 **************** Rollo 5: Kein Wert
    2017-04-21 18:28:13 Periodic : End
    2017-04-21 18:29:10 Periodic : Start
    2017-04-21 18:29:32 Periodic : End
    2017-04-21 18:30:08 Periodic : Start
    2017-04-21 18:30:22 Event : Scene “globalscene.php” is already running.
    2017-04-21 18:30:26 Periodic : End
    2017-04-21 18:31:07 Periodic : Start
    2017-04-21 18:31:08 Periodic : End
    2017-04-21 18:31:54 Periodic : End
    2017-04-21 18:32:07 Periodic : Start
    2017-04-21 18:32:43 Periodic : End
    2017-04-21 18:33:09 Periodic : Start
    2017-04-21 18:33:56 Periodic : End
    2017-04-21 18:34:09 Periodic : Start
    2017-04-21 18:35:08 Periodic : Start
    2017-04-21 18:35:09 Periodic : End
    2017-04-21 18:36:08 Periodic : Start
    2017-04-21 18:36:16 Periodic : End

    ???

    #11651

    macgreg0r
    Participant

    hello,

    the service is down again:
    2017-04-21 03:34:00 Periodic : Start
    2017-04-21 03:34:05 Periodic : Scene “ma scene.php” deactivate
    2017-04-21 03:34:06 Periodic : End
    2017-04-21 03:35:01 Periodic : Start
    2017-04-21 03:35:06 Periodic : Scene “ma scene.php” deactivate
    2017-04-21 03:35:06 Periodic : End
    2017-04-21 03:36:00 Periodic : Start
    2017-04-21 03:37:00 Periodic : Start
    2017-04-21 03:38:01 Periodic : Start
    2017-04-21 03:39:01 Periodic : Start
    2017-04-21 03:40:01 Periodic : Start

    but this time php like is still there:
    ls -lrt /usr/bin/php
    lrwxrwxrwx 1 root root 20 Apr 19 14:28 /usr/bin/php -> /usr/local/bin/php56

    I didn’t do any update, I was sleeping at that time. what the hell is going on with scene service?
    restarting core service and scene is back to work again. Does this can be du to a sort of memory leak?

    • This reply was modified 1 year, 6 months ago by  macgreg0r.
    #11676
    Miss Laura
    Miss Laura
    Moderator

    This can be caused by following reasons:
    1) You installed a Synology update (not the case here)
    2) php -m does not list mysql (not the case here)
    3) Your Synology was heavily loaded and because of this a file could not be loaded inside PulseStation, causing it to break.
    In this case check all services in health check to see whether any file is corrupt.
    If nothing is corrupt, just restart the core and the scene service to fix it.
    Prevent heavy applications from blocking your Synology

    For me it keeps on running.

    Have fun,
    Laura

    #11684

    macgreg0r
    Participant

    What do you mean by heavily loaded?
    It crash at hour that I’m not at home or sleeping?! I have not installed new things on it since mounth (except updates). My syno is loaded during virus periodic scans, but crashes didn’t occur in those hours (yet).
    Or DSM 6.1 is consuming more CPU.
    In 4 days it crashed 2 times. And I think it could be more, because I did’nt restart it just after crash.
    Scene service is KO, so I’ve activated checked healcheck service and set it to scan every 1 minute: the log is empty, like if healthcheck is not running. Even after a restart (and scene service is running OK) there is no healthcheck logs, is that normal?

    #11685

    macgreg0r
    Participant

    With last synology update, I had to restore PHP link again etc…
    And after checking that all services are running OK, I noticed that Zwave service was logging like hell!
    And that my zwave devices aren’t responding each time, or with a delay.
    As I already encounter this issue, I ‘ve do the “clear config file” thing.
    Now all is working normaly (I had a little issue with Fibaro smoke Zwave+ sensor , that I had to reintegrate manualy).
    Since that scene service is working normaly.
    Maybe that the charge Miss Laura was talking about…

    I hope this will continue to work.

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.