Problems after last DSM Update

Free domotica! Forums How can I …? Synology NAS Problems after last DSM Update

This topic contains 1 reply, has 2 voices, and was last updated by Miss Laura Miss Laura 1 year, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #3560

    Morbidia
    Participant

    Hey Mikael, Hey PulseStation Team,

    first i want to say thank you for this software. I really like it even though i still have some problems understanding and using all features.

    But on to my problem and what i dislike on your package:

    I use Pulsestation on my synology and i really can’t understand why i would have to reinstall PS after every DSM Update. I do understand that the needed drivers for zwave usb support need to be reinstalled, but the whole package? everytime i do an update i completely need to re-setup my system. Install all services, buttons, scenes, etc. add all zwave devices again, re-write my blockly rules.
    Shouldn’t there be an easier way? Or at least a possibility (maybe i just didn’t find it yet) to backup all those things?

    On top of all of that since todays DSM update i get a /dev/ttyACM0 ( Permissions problem!)

    i can’t figure out where this error comes from. i found a thread in here from 2015 that pointed to some chmod change but that also didn’t do the trick.
    Any advice?

    Kind regards,
    Morbidia

    • This topic was modified 1 year, 4 months ago by  Morbidia.
    #3562
    Miss Laura
    Miss Laura
    Moderator

    Hi,

    First advise: never update DSM to the latest version the first week.
    That gives us some time to test it ourselves and make fixes if needed.
    Synology never gives us updates in advance, so we always need to find out afterwards.

    Second advise: Inside PulseStation administration panel, go to Add-ons and install the “Backup” service. Refresh the page.
    Then go to the Services menu on the left and click on Backup.
    You can now create manual backups, the same way you would add devices, with the button on the right. I do recommend giving every backup an easy to recognize name.
    You can also restore backups with this service.

    Third advise: I’ve never had to reinstall PulseStation after an update of either DSM or PulseStation itself.
    Why do you think you need to reinstall PulseStation? Does something always stop working?

    Then for the permission problem:
    Option 1) Try to reboot your Synology and check whether the key becomes available again
    Option 2) Check using the dmesg command from our faq whether the key is still on that port, maybe it’s changed. Then change it inside the PulseStation zwave service configuration.
    Option 3) Once you know the correct port you can try following command:
    chmod 777 /dev/name-of-your-port

    This should work. If still not, I wouldn’t really know how to fix it.
    Maybe we can look together via live chat then…

    Have fun,
    Laura

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.