Roller Shutter 2 FGRM-222 Parameters

Free domotica! Forums How can I …? Synology NAS Roller Shutter 2 FGRM-222 Parameters

This topic contains 26 replies, has 7 voices, and was last updated by  LoJaume 1 year, 4 months ago.

Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • #2706

    LoJaume
    Participant

    Hi!

    After some trials, I could include my Fibaro Shutter-2 (FGRM-222) module in z-wave service. I want to configure the parameters to calibrate the shutter, as explained in this tutorial link:

    But, in my zwave device properties tab, their values are completely different from what can be expected from a shutter. For exemple, There isn’t any way to force roller shutter calibration. In fact, there are only 5 properties pages, not 10 pages as in tutorial.

    I thought the zwave device could be bad identified, and I erased and included module again, but nothing has changed. I could force calibration using B-button in module, and I can move the shutter changing some parameters, but there are still some parameters I need to change to calibrate the shutter.

    What I did wrong?

    #2716

    K.Rens
    Keymaster

    Can you share a screenshot of how this roller shutter is associated?
    It’s next to the properties tab.

    It may be related to this, in the beta build we have made some improvement on the association.

    Kind regards,
    K.Rens

    #2730

    herve
    Participant

    Hi,
    I am in the same situation.I have just installed a FGRM-222 and cannot see the calibration page.
    I can control my shutter wit only 2 phases: opened, closed.
    I think the first problem is that the FGRM-222 is recognized as:
    Type = “Motor Control Class B”
    Product = “Unkown: type=0302, id=1000”
    The communication seems to be ok as I can control my shutter but for a full open or close mode. Test Node is correct (=ControllerState_NodeOK)
    In regards to the properties I don’t know how to share a screenshot with you), there are 6 pages with the following fields for each page:
    . Page 1: Switch, Level, Open, Close, Ignore Start Level
    . Page 2: Start Level, Dimming Duration, Step Size, Inc (button), Dec (button)
    . Page 3: Power, Energy, Power, Exporting, Reset (button)
    . Page 4: Powerlevel, Timeout, Set Powerlevel, Test Node, test Powerlevel
    . Page 5: Frame Count, Test (button), Report (button), Test Status, Acked Frames
    . Page 6: Protection=Unprotected, Livrary Version=3, Protocol Verison=3.52, Application Version=25.25

    I hope this helps.
    Best Regards,
    Hervé.

    #2733

    LoJaume
    Participant

    Yes, the some properties than Hervé. I also have a “Motor Control Class B” type, but I can change the “level” property, from 0 to 99, and roller shutter puts in the correspondent position

    As you suggest, I copy associations tab.

    Associations tab

    (zwave-1 is the USB zwave dongle in NAS)

    • This reply was modified 1 year, 5 months ago by  LoJaume.
    • This reply was modified 1 year, 5 months ago by  LoJaume.
    #2742
    Mika
    Mika
    Keymaster

    As you said, you have the product recogninze as “Unkown: type=0302, id=1000”.
    It means that the openzwave librairy doesnt have this product in their config file.

    Here are the steps to add it :

    * Search for the file “/web/PulseStation/services/zwave/config/manufacturer_specific.xml”
    * In that file search for “fgrm222.xml”
    * Add a new line like this, just below the existing one : *Go to the zwave service, controller commands , remove config files

    It will restart the zwave service and normally once you interact with your device you should see FGRM 222 Roller Shutter Controller 2 instead of unknow type.

    #2751

    LoJaume
    Participant

    Uf, I’ve updated the file and reset controller (remove config files did npthing).

    But now, it’s impossible to recogniza USB dongle

    Always “ERROR: Cannot open serial port /dev/ttyACM0. Error code 2”

    I’ve reboot NAS twice, and I think I’ve tried all.

    Bad day. :o/

    #2753
    Mika
    Mika
    Keymaster

    I tell you to remove config files not reset the controller…:-(
    Did you try to unplug, replug the controller.
    Error code 2 is file not found…

    #2756

    LoJaume
    Participant

    I reset the controller because remove config files (from menú) didn’t do nothing.

    Well, I will try to reset Aegon Gen5 dongle through reset button. It’s the only thing I haven’t still tried.
    Anyway, I’m very disappointed about that.

    #2758
    Mika
    Mika
    Keymaster

    How did you saw that the remove config files didnt work ?
    Because, it restart directly the service so the files are directly re-generated.

    #2763

    LoJaume
    Participant

    Well, the service was not restarted. I tried several times remove config files, from menu, and nothing happened. I also restarted zwave service manually, and nothing had changed.
    Finally, I reseted controller, from menu, and now it seems impossible to reinstall.

    #2766

    LoJaume
    Participant

    Uf, I finally could solve the problems. I reseted Aegon Gen5 USB dongle, pressing 20 sec the reset button, and then I included Fibaro roller shutter.

    Now, the FGRM-222 is well recognized, and I have 10 properties pages, including “Force callibration”.
    I have to tweak the parameters, because in Dashboard continues a bulb. :o/ And, There is no feedback -or value returned- in Imperihome. Have you any recommended parameter values?

    #2782

    herve
    Participant

    on my side, adding the following line in the file: /web/PulseStation/services/zwave/config/manufacturer_specific.xml

    <Product type=”0302″ id=”1000″ name=”FGRM222 Roller Shutter Controller 2″ config=”fibaro/fgrm222.xml”/>

    fixed my problem. I have just installed my 2nd FGRM-222 successfully.
    That’s great. Thanks Mika.

    #2783
    Mika
    Mika
    Keymaster

    keep in mind that if there is a new version of the zwave service (if i didnt upgrade the openzwave lib) it will overwrite your file so you’ll have to do that again…

    #2785

    LoJaume
    Participant

    of course.
    Thank you. Merci beaucoup.

    • This reply was modified 1 year, 5 months ago by  LoJaume.
    #2820

    coldbringer
    Participant

    Hey, I have a couple of roller shutters in place. Which parameters do you mean? You need to configure the switch type correctly and that’s about it. Auto-calibration does the rest. If you have further questions, maybe I can help.

Viewing 15 posts - 1 through 15 (of 27 total)

You must be logged in to reply to this topic.