Adding new devices doesn't work

Domotica gratuit Forums How can I …? Synology NAS Adding new devices doesn't work

Ce sujet a 32 réponses, 3 participants et a été mis à jour par Miss Laura Miss Laura, il y a 2 ans et 5 mois.

15 sujets de 16 à 30 (sur un total de 33)
  • Auteur
    Messages
  • #3456

    teeltom
    Participant

    Hi Laura
    unfortunately it stll doesnt work.
    What i tried: fresh install (even PHP), change webserver from apache to nginx
    No luck, no self-created identification.json’s

    #3459

    teeltom
    Participant

    Hi me again
    i played around a little and found out:
    owner of /web/Pulsestation can be unchanged at root:root (after fresh install)
    If i install a service, a corresponding .json file is created automatically in data directory with owder http:http and 644 rights.
    Still no identification.json written
    I’d apreciate help alot because i wouldnt want to buy an extra zwave gateway

    Thanks in advance
    Tom

    #3460
    Miss Laura
    Miss Laura
    Modérateur

    I’ve forwarded your request to the lead developer.
    He’s away at this time, so it may take a while for him to get back to you though…

    Have fun,
    Laura

    #3461

    teeltom
    Participant

    Thank you

    #3471

    teeltom
    Participant

    Hi guys
    i just wanted to be honest and tell you that i switched to another solution because i fuzzed around too long with PulseStation with no success. Sorry for this, perhaps i’ll give it a try again someday

    🙂

    #3472
    Miss Laura
    Miss Laura
    Modérateur

    Sorry to hear that, but no hard feelings. 😉
    We just want you to be happy, doesn’t matter which solution you choose.

    Out of curiosity: which one did you choose?

    I’ve tried Domoticz, but it was so difficult to create rules and to get all my devices listed, that I immediately switched back to PulseStation 😉

    Fyi: we would have looked together on your computer if you contacted us via live chat.

    Have fun,
    Laura

    #3473

    teeltom
    Participant

    Hi Laura
    apparently it is Domoticz 🙂

    Advantages from my point of view:
    – no MariaDB and no PHP customziations needed which makes the whole DSM less complex and thus less vulnerable. I have PHP installed anyway so i cannot say if this is mandatory for Domoticz.
    – Since Domoticz is on the market for quite some time now, their Wiki is quite big and thus full of Howtos, script and blockly examples etc
    – Security network key for z wave is already set on install, no need to look in forums
    – there are native iOS apps (Pilot and Domotix) with no need to install an addon (Imperihome)

    The result was:
    After about 2 hours (look am am completely new to this) i got:
    – my Synology sensors (CPU, Mem, HDD etc..) recognized correctly and reporting
    – Homebase weather (wind, temp, rain etc) via builtin Forecast IO (free account needed)
    – push notifications sent with Prowl (free Prowl account+API key needed)
    – my first z wave device (a Fibarro plug) reporting the power usage and consumption of my fridge correctly

    Blockly seems quite restricted by design though but i cannot compare it to Pulsestation anymore.
    But scripts (Lua, Python and bash) are also supported.
    Domoticz also offers kinda distributed setup with one master and one ore more clients. I stumbled upon this option by chance but since all hardware i want to have added is located in different floors in the house with bad z wave range, i will use this feature as soon as i can afford a second DS.

    🙂
    Tom

    #3474
    Miss Laura
    Miss Laura
    Modérateur

    Don’t buy a second PS, buy a much cheaper second raspberry pi 😉

    – the PHP modifications are not needed on all models, but some special models do,
    that’s why it’s recommended for all.
    The same issue will happen for Domoticz 😉

    – The way PulseStation communicates with MariaDB is much more secure then using the internal database of Domoticz. So yes, it’s easier, but less secure.

    – Howto’s: you are right. But I read their wiki’s and then still didn’t always understood it.
    I’ve spent hours trying to set-up a simple alarm.
    Inside PulseStation I had set it up in minutes, just drag and drop 🙂

    – Their native apps feel very laggy and have small buttons to switch devices.
    I prefer Imperihome – and that’s difficult to link to Domoticz, you need to put a proxy in between.
    But just personal feeling.

    – Push notifications inside PulseStation are also easy, just install Pushover and enter your api key. So no difference there.

    – The zwave security key didn’t populate automatically for me in Domoticz, had to google for it and put it in manually. So that may depend on the usb key you are using.

    – You are right, sensors of the dsm itself are currently not there. Good feedback, thank you!

    – Homebase weather: PulseStation has Yahoo weather, so that’s identical.

    – Was the power reporting inside PulseStation wrong? For me it seems to be working correctly and it’s supported immediately inside it.

    Thank you for the great feedback, I will take some points out of it in order to improve PulseStation.
    Do not hesitate to let me know if you find other things we could do 🙂

    Have fun,
    Laura

    #3475

    teeltom
    Participant

    Hi Laura
    all the things you posted that Pulsestation could do are fine, but i spent a whole week to get it working (just have a look at this posts post dates). So compare one week to aprox. 2 hours and you have your argument.
    And yes, i will buy another DS (a one drive device) beacause i can use it as backup destination from my first DS to have redundancy if necessary 😉

    #3476
    Miss Laura
    Miss Laura
    Modérateur

    Héhé, good point.
    Next time just reach out for a teamviewer session, that we can help directly.

    Backup: excellent reason.

    Have fun,
    Laura

    #3477

    xcasamia
    Participant

    Something like the same problem… I solved restarting NAS, and restarting manually all service in pulsestation…

    Another question,
    yahoo finance sometimes loose the name of “Finance.Symbol”, I’ve got two devices and the service loose one or the other or both of them apparently with no reason….
    may you help me?

    Thank you all

    #3478

    xcasamia
    Participant

    ALSO… I must change the HD in the nas… first was a WD 2TB red, it brokes, so I take an old 250GB with 8mb cache, really all the NAS increment a lot response, and the pulse station has no lag, also using from remote…
    sometimes when you change some field, you need to wait 5 to 10 second and clik on other field to see the modification.
    bye

    Thank you all

    #3524
    Miss Laura
    Miss Laura
    Modérateur

    Yahoo finance: just added 2 stocks.
    Will test it the coming days.

    Do you mean the lag issue is solved or not, since that isn’t clear.
    And where is it slower or faster exactly?
    The more services you are running and the more often you check for updates, the heavier for your hardware.

    Have fun,
    Laura

    #3586

    xcasamia
    Participant

    Hi, sorry to be late,

    The sequence:
    I put example “amazn” in field Finance.Symbol, and after a while it works… I can see the value in the dashboard and on push notification once a day.
    But after one or two days, the value in field disappear in pulsestation fiedl and obviously also in pushover.

    Thank you,
    Dario

    Thank you all

    #3588
    Miss Laura
    Miss Laura
    Modérateur

    Hi,

    After your last message I added some shares and I can confrim now that after several days the Symbols are missing.
    We will investigate the code in order to try to find out what is overwriting it.

    Have fun,
    Laura

15 sujets de 16 à 30 (sur un total de 33)

Vous devez être connecté pour répondre à ce sujet.