[Résolu] Aeotec Z-Stick not working with either USB-Port

Domotica gratuit Forums Report a bug Aeotec Z-Stick not working with either USB-Port

Ce sujet a 7 réponses, 4 participants et a été mis à jour par  Jodox, il y a 1 an et 6 mois.

8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #2372

    Jodox
    Participant

    Hello,

    I tried the Aeotec Z-Stick Gen5 on my DS213+ with both USB ports /dev/ttyACM0 and /dev/ttyUSB0 but I always get logs like this:

    2016-01-09 03:26:51.150 Always, OpenZwave Version 1.3.0 Starting Up
    2016-01-09 03:26:51.150 Info, Setting Up Provided Network Key for Secure Communications
    2016-01-09 03:26:51.151 Info, mgr, Added driver for controller /dev/ttyUSB0
    2016-01-09 03:26:51.151 Info, Opening controller /dev/ttyUSB0
    2016-01-09 03:26:51.151 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-09 03:26:51.151 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2016-01-09 03:26:51.151 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2016-01-09 03:26:51.151 Warning, WARNING: Failed to init the controller (attempt 0)
    2016-01-09 03:26:56.152 Info, Opening controller /dev/ttyUSB0
    2016-01-09 03:26:56.152 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-09 03:26:56.152 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2016-01-09 03:26:56.152 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2016-01-09 03:26:56.152 Warning, WARNING: Failed to init the controller (attempt 1)
    2016-01-09 03:27:01.152 Info, Opening controller /dev/ttyUSB0
    2016-01-09 03:27:01.152 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-09 03:27:01.152 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2016-01-09 03:27:01.153 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2016-01-09 03:27:01.153 Warning, WARNING: Failed to init the controller (attempt 2)
    2016-01-09 03:27:06.153 Info, Opening controller /dev/ttyUSB0
    2016-01-09 03:27:06.153 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-09 03:27:06.153 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2016-01-09 03:27:06.153 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2016-01-09 03:27:06.153 Warning, WARNING: Failed to init the controller (attempt 3)
    2016-01-09 03:27:11.153 Info, Opening controller /dev/ttyUSB0
    2016-01-09 03:27:11.153 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-09 03:27:11.153 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2016-01-09 03:27:11.154 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2016-01-09 03:27:11.154 Warning, WARNING: Failed to init the controller (attempt 4)
    2016-01-09 03:27:11.154 Detail, contrlr, Notification: DriverFailed
    2016-01-09 03:27:11.154 Warning, WARNING: Tried to write driver config with no home ID set
    2016-01-09 03:27:11.154 Info, mgr, Manager::WriteConfig completed for driver with home ID of 0x00000000

    2016-01-09 03:33:02.947 Always, OpenZwave Version 1.3.0 Starting Up
    2016-01-09 03:33:02.948 Info, Setting Up Provided Network Key for Secure Communications
    2016-01-09 03:33:02.948 Info, mgr, Added driver for controller /dev/ttyACM0
    2016-01-09 03:33:02.948 Info, Opening controller /dev/ttyACM0
    2016-01-09 03:33:02.949 Info, Trying to open serial port /dev/ttyACM0 (attempt 1)
    2016-01-09 03:33:02.949 Error, ERROR: Cannot open serial port /dev/ttyACM0. Error code 2
    2016-01-09 03:33:02.949 Error, ERROR: Failed to open serial port /dev/ttyACM0
    2016-01-09 03:33:02.949 Warning, WARNING: Failed to init the controller (attempt 0)
    2016-01-09 03:33:07.949 Info, Opening controller /dev/ttyACM0
    2016-01-09 03:33:07.949 Info, Trying to open serial port /dev/ttyACM0 (attempt 1)
    2016-01-09 03:33:07.949 Error, ERROR: Cannot open serial port /dev/ttyACM0. Error code 2
    2016-01-09 03:33:07.950 Error, ERROR: Failed to open serial port /dev/ttyACM0
    2016-01-09 03:33:07.950 Warning, WARNING: Failed to init the controller (attempt 1)
    2016-01-09 03:33:12.950 Info, Opening controller /dev/ttyACM0
    2016-01-09 03:33:12.950 Info, Trying to open serial port /dev/ttyACM0 (attempt 1)
    2016-01-09 03:33:12.950 Error, ERROR: Cannot open serial port /dev/ttyACM0. Error code 2
    2016-01-09 03:33:12.950 Error, ERROR: Failed to open serial port /dev/ttyACM0
    2016-01-09 03:33:12.950 Warning, WARNING: Failed to init the controller (attempt 2)
    2016-01-09 03:33:17.950 Info, Opening controller /dev/ttyACM0
    2016-01-09 03:33:17.950 Info, Trying to open serial port /dev/ttyACM0 (attempt 1)
    2016-01-09 03:33:17.950 Error, ERROR: Cannot open serial port /dev/ttyACM0. Error code 2
    2016-01-09 03:33:17.951 Error, ERROR: Failed to open serial port /dev/ttyACM0
    2016-01-09 03:33:17.951 Warning, WARNING: Failed to init the controller (attempt 3)
    2016-01-09 03:33:22.951 Info, Opening controller /dev/ttyACM0
    2016-01-09 03:33:22.951 Info, Trying to open serial port /dev/ttyACM0 (attempt 1)
    2016-01-09 03:33:22.951 Error, ERROR: Cannot open serial port /dev/ttyACM0. Error code 2
    2016-01-09 03:33:22.951 Error, ERROR: Failed to open serial port /dev/ttyACM0
    2016-01-09 03:33:22.951 Warning, WARNING: Failed to init the controller (attempt 4)
    2016-01-09 03:33:22.951 Detail, contrlr, Notification: DriverFailed
    2016-01-09 03:33:22.951 Warning, WARNING: Tried to write driver config with no home ID set
    2016-01-09 03:33:22.951 Info, mgr, Manager::WriteConfig completed for driver with home ID of 0x00000000

    #2373

    Coyote
    Membre

    Hi,

    Maybe you can try with /dev/ttyACM1 (or /dev/ttyUSB1).

    With my DS213j, I have to switch between ttyACM1 and ttyACM0 at each reboot of the NAS.

    JMarc

    #2374

    Jodox
    Participant

    No luck with both of your suggestions.

    Jodox

    #2376

    Jodox
    Participant

    Any other ideas?
    Would be sad, if I don’t get this z-wave stick running with either Pulse Station or Domoticz. Does nobody have the same hardware and can give me some hints what to try?

    Jodox

    #2380

    Jodox
    Participant

    Deleting and reinstalling the Z-Wave service several times did the trick.
    (I hate it, when bugs are not logical… How do I know that I just have to do everything that failed before just a few more times for it to succeed?)

    Jodox

    #2383

    K.Rens
    Admin bbPress

    You got error code 2.
    In unix this means: file not found.

    So no clue what you did, but somehow it started finding the file.

    Kind regards,
    K.Rens

    #2419
    Mika
    Mika
    Admin bbPress
    #2430

    Jodox
    Participant

    @Mika: I had used /dev/ttyACM0, /dev/ttyACM1, /dev/ttyUSB0 and /dev/ttyUSB1 without any success. After I reinstalled the z-Wave service, everything is working fine with /dev/ttyACM0.

    Greetings, Jost

8 sujets de 1 à 8 (sur un total de 8)

Vous devez être connecté pour répondre à ce sujet.