Controlleur ZME_UZB1 compatible ?

Domotica gratuit Forums How can I …? Synology NAS Controlleur ZME_UZB1 compatible ?

Mots-clés : , ,

Ce sujet a 15 réponses, 5 participants et a été mis à jour par  K.Rens, il y a 1 an et 7 mois.

15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #1413

    Talard
    Participant

    Salutation !

    Je reçois à l’instant un controlleur ZME_UZB1 que j’ai acheter dans le but d’essayer Pulse Station.
    Comme je ne suis pas parvenu à executer une commande sur le controlleur, j’ai vérifier les logs :

    2015-10-12 18:40:55.216 Always, OpenZwave Version 1.3.0 Starting Up
    2015-10-12 18:40:55.216 Info, mgr, Added driver for controller /dev/ttyUSB0
    2015-10-12 18:40:55.217 Info, Opening controller /dev/ttyUSB0
    2015-10-12 18:40:55.217 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2015-10-12 18:40:55.217 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2015-10-12 18:40:55.217 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2015-10-12 18:40:55.217 Warning, WARNING: Failed to init the controller (attempt 0)
    2015-10-12 18:41:00.218 Info, Opening controller /dev/ttyUSB0
    2015-10-12 18:41:00.218 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2015-10-12 18:41:00.218 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2015-10-12 18:41:00.219 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2015-10-12 18:41:00.219 Warning, WARNING: Failed to init the controller (attempt 1)
    2015-10-12 18:41:05.220 Info, Opening controller /dev/ttyUSB0
    2015-10-12 18:41:05.220 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2015-10-12 18:41:05.220 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2015-10-12 18:41:05.220 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2015-10-12 18:41:05.221 Warning, WARNING: Failed to init the controller (attempt 2)
    2015-10-12 18:41:10.222 Info, Opening controller /dev/ttyUSB0
    2015-10-12 18:41:10.222 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2015-10-12 18:41:10.222 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2015-10-12 18:41:10.222 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2015-10-12 18:41:10.223 Warning, WARNING: Failed to init the controller (attempt 3)
    2015-10-12 18:41:15.224 Info, Opening controller /dev/ttyUSB0
    2015-10-12 18:41:15.224 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2015-10-12 18:41:15.224 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2015-10-12 18:41:15.224 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2015-10-12 18:41:15.224 Warning, WARNING: Failed to init the controller (attempt 4)
    2015-10-12 18:41:15.225 Warning, WARNING: Tried to write driver config with no home ID set
    2015-10-12 18:41:15.225 Info, mgr, Manager::WriteConfig completed for driver with home ID of 0x00000000

    J’avais vérifier ici( https://github.com/OpenZWave/open-zwave/blob/master/config/manufacturer_specific.xml ) que le controlleur était référencé comme compatible, je pensais donc que l’installation allait se passer sans problème.

    Ai-je fait une erreur quelque part ?

    #1416

    K.Rens
    Admin bbPress

    J’ai le meme controlleur et il fonctionne bien.

    N’utilise pas “ttyUSB0” mais “ttyACM0” dans les settings du service z-wave.

    Kind regards,
    K.Rens

    #1418

    Talard
    Participant

    hoooo ! merci pour l’info !

    #1548

    ds32
    Participant

    Bonjour

    J’installe ce jour le meme controlleur derrière mon NAS Synology
    Bien que j’ai modifié le port, j’ai un message d’erreur similaire

    2015-10-29 16:40:01.430 Always, OpenZwave Version 1.3.0 Starting Up
    2015-10-29 16:40:01.431 Info, mgr, Added driver for controller /dev/ttyACM0
    2015-10-29 16:40:01.433 Info, Opening controller /dev/ttyACM0
    2015-10-29 16:40:01.433 Info, Trying to open serial port /dev/ttyACM0 (attempt 1)

    2015-10-29 16:40:21.436 Error, ERROR: Cannot open serial port /dev/ttyACM0. Error code 13
    2015-10-29 16:40:21.436 Error, ERROR: Failed to open serial port /dev/ttyACM0
    2015-10-29 16:40:21.436 Warning, WARNING: Failed to init the controller (attempt 4)
    2015-10-29 16:40:21.436 Warning, WARNING: Tried to write driver config with no home ID set
    2015-10-29 16:40:21.436 Info, mgr, Manager::WriteConfig completed for driver with home ID of 0x00000000

    J’ai l’impression que la NAS n’a pas pris en compte le périphérique sur son port USB. D’ailleurs quand je fais la commande dmesg | grep tty en ssh (cf FAQ comment vérifier que ma clé est bien détectée), je ne retrouve pas une ligne du type
    “usb 1-1.3: cp210x converter now attached to ttyUSB0”

    Y’a t’il qqchose à faire sur le NAS au moment d’insérer la clé ZWave ?

    Samuel

    #1549

    K.Rens
    Admin bbPress

    Apres insérer la clé, c’est toujours mieux de faire un reboot du NAS.
    Certainement si c’est le premier fois que tu utilise le cle.

    Apres le reboot, vérifiez avec dmesg | grep tty le nom du port qui est utilisée.

    Kind regards,
    K.Rens

    #1560

    ds32
    Participant

    Bonjour

    Merci de ta réponse,j’ai refait la manip
    – inserer clé
    – reboot NAS
    – commande ssh –> voici le résultat

    root@DiskStation:~# dmesg | grep tty
    [ 0.000000] Kernel command line: console=ttyS0,115200 ip=off initrd=0x8000040,8M root=/dev/md0 rw syno_hw_version=DS213jv10 ihd_num=2 netif_num=1 flash_size=8
    [ 3.502894] serial8250.0: ttyS0 at MMIO 0xf1012000 (irq = 41) is a 16550A
    [ 4.128855] console [ttyS0] enabled
    [ 4.132760] serial8250.1: ttyS1 at MMIO 0xf1012100 (irq = 42) is a 16550A
    [ 54.585065] cdc_acm 1-1:1.0: ttyACM0: USB ACM device

    j’ai l’impression que ma clé n’est pas reconnue. Une piste (je suis en DSM 6.0 Beta, peut etre me faut il installer des drivers spécifiques pour la clé). Si oui, ou les trouver ?

    Samuel

    #1591
    Mika
    Mika
    Admin bbPress

    Bonjour,

    Voila le “problème”, à l’heure actuelle, DSM6 n’est pas supporté.
    Synology n’a pas encore fourni les tools nécessaire pour pouvoir compiler l’ensemble des services PulseStation.

    Je vais essayer de me renseigner auprès d’eux pour essayer de débloquer la situation…

    Mika

    #1615

    ds32
    Participant

    merci à toi, tout semble s’expliquer. A suivre grace à ton aide.

    #2151

    ds32
    Participant

    hello Mika

    As tu du neuf sur la compatilité Pulstation et DSM 6 ?

    Samuel

    #2152

    K.Rens
    Admin bbPress

    Nous sommes a la recherce de personnes avec un DSM 6 qui veulent tester avec nous les pacquets.

    Nous garantissez pas encore que tout fonctionne, mais nous n’avons pas de machines pour faire cette DSM 6 developpement pour l’instant.

    Donc, n’hesite pas a nous contacter si vous voulez nous aider.

    Kind regards,
    K.Rens

    #2156
    Mika
    Mika
    Admin bbPress

    Je n’ai pas mieux a dire que Koen.
    Si tu es intéressé pour DSM6 contacte moi par mail, je peux facilement adapter le paquet existant pour que tu puisses tester sur DSM6.

    D’après mes premières recherches, je n’ai pas trop l’impression qu’ils y aient de grosses modifications en ce qui me concerne…

    #2170

    K.Rens
    Admin bbPress

    I’ve made a package for you.
    Can you please try manually installing it via the package center?

    https://www.pulse-station.com/PulseStation_1.3.0.spk

    This MAY work on dsm 6.0

    • Cette réponse a été modifiée le il y a 1 an et 7 mois par  K.Rens.

    Kind regards,
    K.Rens

    #2184

    ds32
    Participant

    ok je veux bien tester Pulse-station et DSM6

    #2191

    hermod
    Participant

    I wish that i could read all these post’s in english.

    #2192

    hermod
    Participant

    I have the ZME_UZB1 Controller. I managed to delete the device. Now i cannot get it back. Have tried to reinstall Pulse-Station.

15 sujets de 1 à 15 (sur un total de 16)

Vous devez être connecté pour répondre à ce sujet.