Pulse Station installation on PI

Domotica gratuit Forums How can I …? Raspberry Pi Pulse Station installation on PI

Mots-clés : 

Ce sujet a 34 réponses, 9 participants et a été mis à jour par  K.Rens, il y a 3 ans et 2 mois.

15 sujets de 16 à 30 (sur un total de 35)
  • Auteur
    Messages
  • #1374
    Mika
    Mika
    Admin bbPress

    Can you check if that folder contains files and folders ?

    #1376

    Maybe
    Participant

    I removed the folder advised by floonder and reinstalled. Now PulseStation does exist and contains files and folders but still unable to connect in browser.

    I don’t know if I will continue with PulseStation. Quite a hassle to get it running and personally I’m not really happy with OZW library, had too many device mismatches in the past that is why I stopped with other open source software based on OZW.

    #1378
    Mika
    Mika
    Admin bbPress

    Do you know other open source library?
    Maybe i can propose other zwave service based on another library…

    What is the result of the command “ls -l /var/www”?

    #1379

    djoul2706
    Participant

    Hi,
    What is the best way to restart Pulse Station on the raspberry ?
    When I do it with ./core/core it seems to start but I’m stuck on the login page…
    regards,
    Julien

    #1380

    Maybe
    Participant

    ls -l /var/www

    drwxr-xr-x 1 root root 20 okt 4 23:33 html
    lrwxrwxrwx 1 root root 23 okt 5 20:42 PulseStation -> /usr/share/PulseStation
    drwxrwxrwx 1 root root 0 okt 5 18:53 PulseStationBackup

    #1384

    jamat
    Participant

    In my case

    total 8
    drwxr-xr-x 2 root root 4096 Oct 4 21:16 html
    lrwxrwxrwx 1 root root 23 Oct 5 21:35 PulseStation -> /usr/share/PulseStation
    drwxrwxrwx 2 root root 4096 Oct 4 21:53 PulseStationBackup

    I have installed three times with the same results

    Jordi

    #1385
    Mika
    Mika
    Admin bbPress

    Very strange that you cannot access PulseStation.

    Is your apache server running ?
    Try to restart it via :

    sudo service apache2 restart
    

    What if you create a simple “index.html” file in “/var/www” and add a simple comment in it ?
    Did you have access ?

    #1388

    Maybe
    Participant

    Is your apache server running ?

    What if you create a simple “index.html” file in “/var/www” and add a simple comment in it ?
    Did you have access ?

    It is running.
    /var/www only contains the standard debian apache welcome index.html.
    Do I have to delete or replace it?

    #1397
    Mika
    Mika
    Admin bbPress

    Try to access that file to see if it’s working…

    #1399

    joern
    Participant

    Hi,
    Looks like a apache configuration Problem depending on your Distribution.
    Go to the console and enter:
    cd /etc/apache2/sites-enabled
    less 000-default

    Is there a a row with:
    Options FollowSymLinks
    and when it is, which entity is around (e.g. <Directory />) ?

    Joern

    #1400

    Maybe
    Participant

    Hi Joern,

    No such line in the conf file.
    Can you provide me the correct line?

    #1410

    Ludovic
    Participant

    Hello, I had the same issue.
    DocumentRoot is set to /var/www/html by default in Apache configuration, you have to set it to /var/www
    Ludo

    #1412

    joern
    Participant

    @maybe
    you have to edit:
    /etc/apache2/sites-enabled/000-default
    and add a line:

    Options FollowSymLinks

    into the <directory>
    like this example:

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>

    and dont!!! forgt to restart your Apache after adding the line:

    sudo /etc/init.de/apache2 restart

    Joern

    #1415

    djoul2706
    Participant

    Hi,
    What is the best way to restart Pulse Station on the raspberry ?
    When I do it with ./core/core it seems to start but I’m stuck on the login page…
    regards,
    Julien

    FYI, I’m not sure if it is related to my install but for me, install script places PulseStation folder in /usr/SHARE/ meanwhile startup script looked into /usr/LOCAL/

    I replace “local” by “share” (in /etc/init.d/PulseStation) and it start properly on boot now !

    #1419

    Maybe
    Participant

    sudo /etc/init.de/apache2 restart

    Thx Ludo,

    that THE answer 😉

15 sujets de 16 à 30 (sur un total de 35)

Vous devez être connecté pour répondre à ce sujet.