Siren Aeotec Gen5 – Modify the volume in blocky ?

Domotica gratuit Forums How can I …? Synology NAS Siren Aeotec Gen5 – Modify the volume in blocky ?

Mots-clés : 

Ce sujet a 5 réponses, 4 participants et a été mis à jour par  K.Rens, il y a 1 an.

6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #1764

    Coyote
    Membre

    Hi,

    I have an Aeotec Siren Gen5, and I have a question with blocky rules.
    Since the new OpenZWave release, I have now all parameters for this module.

    I would like to use my siren to validate my house’s alarm when I put it on (But with specific low sound).

    The parameter is oki on my ZWave service, but I can’t see it on my blocky rules.
    If I change this parameter, my siren will always use this sound (for alarm, and to validate the alarm)…

    Is it possible to add specifics parameters in Blocky ?

    Thank you..

    JMarc

    #1766

    K.Rens
    Admin bbPress

    Thank you, this is valuable feedback.
    We’ve added it on our short term todo list, since I had exactly the same problem.

    You can for sure already do it using a custom php block inside blocky, but I need to find out which command to issue.

    • Cette réponse a été modifiée le il y a 1 an et 10 mois par  K.Rens.

    Kind regards,
    K.Rens

    #1775
    Mika
    Mika
    Admin bbPress

    Here is a workaround before I add the functionnality inside blockly itself.

    • First, modify the property via the zwave service and see what happen in the log of the core service. You should see something like this :
      2015-11-16 06:10:12.650  Message In Core : 1|HUB|zwave|UPDATEPROPERTY|zwave-2|37-user-bool-1-0|true
      2015-11-16 06:10:12.917  Forwarding message : 1|HUB|zwave|UPDATEPROPERTY|zwave-2|37-user-bool-1-0|true
      2015-11-16 06:10:14.961  Message Finished, remove it from the stack (0|HUB|HUB|AUTORESTART)
      2015-11-16 06:10:15.043  zwave : Message received - 1|HUB|zwave|UPDATEPROPERTY|zwave-2|37-user-bool-1-0|true|1447650614624|447409f9bfb16fc245d3496fef722b73
      2015-11-16 06:10:15.131  Message Finished, remove it from the stack (1|HUB|zwave|UPDATEPROPERTY|zwave-2|37-user-bool-1-0|true)
      
    • Then, go to your blockly scene and add a php block with the following code :
      //setValue("THE SERVICE","THE DEVICE ID","THE PROPERTY ID","THE VALUE");
      setValue("zwave","zwave-2","37-user-bool-1-0","true");
      

    As you can see all the values you need can be found in the log of the core service.

    Mika.

    #3710

    djandib
    Participant

    I have now the Siren. Aeotec Gen5
    Volume etc. all work fine.
    Question:
    How can I controll the duration of the alarm less <1 minute?
    I want the Alarm only for a second like a carlock Beep-Beep.

    For example:
    IF Time= 13:00
    THEN Turn on Siren
    after 1 Second Turn off Siren

    #3711

    djandib
    Participant

    Live can be so simple 😉
    I made blockly:
    IF Time=14:00
    THEN
    – turn on Siren
    – wait 0.0125 minutes
    – turn off Siren

    It works! 🙂
    BUT unfortunately even if I kill the wait order, it takes about 3 seconds until siren turns off again.

    Any idea?

    #3715

    K.Rens
    Admin bbPress

    It takes some time for zwave devices to process signals.
    It could be that the device itself is not fast enough to process it.

    You could try putting the device as close as possible to your usb key and disabling services you do not need temporarily to decrease load as much as possible.
    You could also try disabling zwave logging, but then you are in the blind if there ever are issues 😉

    Kind regards,
    K.Rens

6 sujets de 1 à 6 (sur un total de 6)

Vous devez être connecté pour répondre à ce sujet.