Z-wave : la clé et les périphérique invisible

Domotica gratuit Forums How can I …? Synology NAS Z-wave : la clé et les périphérique invisible

Mots-clés : 

Ce sujet a 14 réponses, 3 participants et a été mis à jour par  K.Rens, il y a 1 an et 9 mois.

15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #2480

    dplg92
    Participant

    Bonjour,

    J’essai désespérément de mettre en place un petit système domotique pour mes radiateurs mais j’y arrivé pas!!!

    J’ai installé pulsation sur le NAS (synology 415play). Ca semble fonctionné.
    J’installe le service ZWAVE, qui lui aussi semble fonctionné.
    Je me suis assuré que la clé est sur le bon port (ttyUSB0). J’ai une clé Aeon Z-sticl S2.
    Mais elle n’apparait pas! Enfin si une fois, mais a disparu 2 minutes après et pas moyen de la faire réapparaittre….
    J’ai tous réinstallé, recherché un peu partout, mais pas moyen de trouver un truc compréhensible!!!
    Je suis quasi sur que c simple, mais là je tourne en rond!

    J’en ai surement pas assez dit, donc poser moi toutes vos questions pour essayer de me trouver la solution.
    Merci d’avance pour votre aide

    #2481
    Mika
    Mika
    Admin bbPress

    Bonjour,

    Avez vous consulter notre FAQ concernant la reconnaissance de la clé ?
    Je vous y invite.
    Si vous avez d’autres périphériques branché sur vos ports USB, je vous conseille dans un premier temps de les enlever pour etre sur que ce ne soit pas eux.

    Mika

    #2496

    dplg92
    Participant

    Bonjour,

    J’ai regardé partout ou je pouvais regarder (par contre je parle pas trop anglais… ça limite un peu).
    Ensuite, mais je pense pas que ce soit ça, il est fait mention du network key!! et là je vois pas ce qu’il faut faire.. j’ai vu quelque part que ça n’est pas forcement obligatoire de remplir ce champ….
    Je pense faire la bonne procédure!
    Concernant les périphériques sur le NAS; je n’ai que la clé Z-WAVE…
    Ce qui est étrange c’est que ça a fonctionné 3 minutes ce WE!!! je voyais la clé! et puis elle a disparu, et depuis plus rien… malgré les réinstalations, redémarrage du NAS….

    #2497

    K.Rens
    Admin bbPress

    Quelles sont les +/-30 premières lignes du log zwave dans pulsestation?

    Tu as deja essaje le commande “dmesg | grep tty”
    Quelle etait le reponse?

    Kind regards,
    K.Rens

    #2505

    dplg92
    Participant

    Bonjour K.rens
    Alors les premières lignes du lot Zwave :
    2016-01-21 09:44:57.963 Always, OpenZwave Version 1.3.0 Starting Up
    2016-01-21 09:44:57.964 Info, Setting Up Provided Network Key for Secure Communications
    2016-01-21 09:44:57.964 Warning, Failed – Network Key Not Set
    2016-01-21 09:44:57.964 Info, mgr, Added driver for controller /dev/ttyUSB0
    2016-01-21 09:44:57.965 Info, Opening controller /dev/ttyUSB0
    2016-01-21 09:44:57.965 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-21 09:44:57.976 Info, Serial port /dev/ttyUSB0 opened (attempt 1)
    2016-01-21 09:44:57.976 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
    2016-01-21 09:44:57.976 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
    2016-01-21 09:44:57.976 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
    2016-01-21 09:44:57.976 Detail, contrlr, Queuing (Command) FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
    2016-01-21 09:44:57.976 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa
    2016-01-21 09:44:57.977 Detail,
    2016-01-21 09:44:57.977 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x15) – FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
    2016-01-21 09:44:57.980 Detail, contrlr, Received: 0x01, 0x10, 0x01, 0x15, 0x5a, 0x2d, 0x57, 0x61, 0x76, 0x65, 0x20, 0x32, 0x2e, 0x37, 0x38, 0x00, 0x01, 0x9b
    2016-01-21 09:44:57.980 Detail,
    2016-01-21 09:44:57.980 Info, contrlr, Received reply to FUNC_ID_ZW_GET_VERSION:
    2016-01-21 09:44:57.980 Info, contrlr, Static Controller library, version Z-Wave 2.78
    2016-01-21 09:44:57.980 Detail, Node045, Expected reply was received
    2016-01-21 09:44:57.980 Detail, Node045, Message transaction complete
    2016-01-21 09:44:57.980 Detail,
    2016-01-21 09:44:57.980 Detail, contrlr, Removing current message
    2016-01-21 09:44:57.980 Detail,
    2016-01-21 09:44:57.980 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x20) – FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
    2016-01-21 09:44:57.983 Detail, contrlr, Received: 0x01, 0x08, 0x01, 0x20, 0x01, 0x85, 0x2d, 0xa4, 0x01, 0xda
    2016-01-21 09:44:57.983 Detail,
    2016-01-21 09:44:57.983 Info, contrlr, Received reply to FUNC_ID_ZW_MEMORY_GET_ID. Home ID = 0x01852da4. Our node ID = 1
    2016-01-21 09:44:57.983 Detail, Node133, Expected reply was received
    2016-01-21 09:44:57.983 Detail, Node133, Message transaction complete
    2016-01-21 09:44:57.983 Detail,
    2016-01-21 09:44:57.983 Detail, contrlr, Removing current message
    2016-01-21 09:44:57.983 Detail,
    2016-01-21 09:44:57.983 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x05) – FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
    2016-01-21 09:44:57.985 Detail, contrlr, Received: 0x01, 0x04, 0x01, 0x05, 0x1c, 0xe3
    2016-01-21 09:44:57.985 Detail,
    2016-01-21 09:44:57.985 Info, contrlr, Received reply to FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES:
    2016-01-21 09:44:57.985 Info, contrlr, There is a SUC ID Server (SIS) in this network.
    2016-01-21 09:44:57.985 Info, contrlr, The PC controller is an inclusion static update controller (SUC) and was the original primary before the SIS was added.
    2016-01-21 09:44:57.985 Detail, Node227, Expected reply was received
    2016-01-21 09:44:57.985 Detail, Node227, Message transaction complete
    2016-01-21 09:44:57.985 Detail,
    2016-01-21 09:44:57.985 Detail, contrlr, Removing current message
    2016-01-21 09:44:57.985 Detail,
    2016-01-21 09:44:57.986 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x07) – FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
    2016-01-21 09:44:57.991 Detail, contrlr, Received: 0x01, 0x2b, 0x01, 0x07, 0x03, 0x07, 0x00, 0x86, 0x00, 0x02, 0x00, 0x01, 0xfe, 0x80, 0xfe, 0x88, 0x0f, 0x00, 0x00, 0x00, 0xfb, 0x97, 0x7f, 0x82, 0x07, 0x00, 0x00, 0x80, 0x00, 0x80, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0xc2
    2016-01-21 09:44:57.991 Detail,

    Est ce que tu vois quelques chose d’anormal? Perso je comprends rien!
    Du coup, s’il y a un problème je ne sais pas la détectée!!

    Ensuite, oui j’ai fait la commande “dmesg | grep tty”. Voici le résultat
    DiskStation> dmesg | grep tty
    [ 0.000000] console [ttyS0] enabled
    [ 5.498057] serial8250: ttyS0 at I/O 0x3f8 (irq = 38) is a GEN3_serial
    [ 5.517627] serial8250: ttyS1 at I/O 0x2f8 (irq = 38) is a GEN3_serial
    [ 5.541842] serial8250: ttyS2 at I/O 0x3e8 (irq = 38) is a 8250
    [ 159.175345] usb 4-2: cp210x converter now attached to ttyUSB0

    Donc la clé est bien en “ttyUSB0”
    C’est donc ce que j’ai rempli dans le port série

    Une idée?

    #2506

    K.Rens
    Admin bbPress

    Le clé est bien ttyUSB0 chez vous.

    Tu dit que le clé disparais après 3 minutes?
    Elle disparaît ou?

    Comme network key tu peut comme exemple utiliser qqch comme:
    0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08, 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0E, 0x10

    Si tu as windows, tu peut essayer si tu peut voir les appareils avec le IMAtool.
    http://aeotec.com/downloads/IMAToolV1.zip
    Branche le cle usb, demarre IMAtool et dans le menu dropdown activez comx
    Après utilise full scan pour voir toutes vos devices et attends jusque au feux verts.
    Après dites nous les résultats du scan.

    Kind regards,
    K.Rens

    #2511

    dplg92
    Participant

    RE

    La clé disparait de la liste des périphériques du service Z-wave!
    En fait, je ne l’ai vue qu’une fois, avec en dessous le seul périphérique que j’ai installé pour le moment sur un radiateur (Qubino ZMNHJD1S1P1 : radiateur avec fil pilote)

    Depuis, impossible de les revoir pour les configurer et interagir avec depuis pulsestation!

    Je vais regarde ce que donne IMAtool et reviens vous toi

    #2514

    dplg92
    Participant

    Alors voila ce que j’ai lorsque je lance IMAtool
    copie d ecran

    Bizarrement, je n’ai pas de menu ou activer “comx”…

    #2515

    dplg92
    Participant

    copie d ecran

    #2516

    dplg92
    Participant

    Alors, juste pour info.
    Pour faire la manip. avec IMATool, j’ai débranché la clé du NAS pour la mettre sur un PC.
    Lorsque je retranche la clé sur le NAS, voila ce qu’indique le LOG ZWAVE :

    2016-01-21 15:11:20.593 Always, OpenZwave Version 1.3.0 Starting Up
    2016-01-21 15:11:20.594 Info, Setting Up Provided Network Key for Secure Communications
    2016-01-21 15:11:20.594 Info, mgr, Added driver for controller /dev/ttyUSB0
    2016-01-21 15:11:20.594 Info, Opening controller /dev/ttyUSB0
    2016-01-21 15:11:20.595 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-21 15:11:20.595 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2016-01-21 15:11:20.595 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2016-01-21 15:11:20.595 Warning, WARNING: Failed to init the controller (attempt 0)
    2016-01-21 15:11:25.597 Info, Opening controller /dev/ttyUSB0
    2016-01-21 15:11:25.598 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-21 15:11:25.598 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2016-01-21 15:11:25.598 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2016-01-21 15:11:25.598 Warning, WARNING: Failed to init the controller (attempt 1)
    2016-01-21 15:11:30.601 Info, Opening controller /dev/ttyUSB0
    2016-01-21 15:11:30.601 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-21 15:11:30.601 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2016-01-21 15:11:30.601 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2016-01-21 15:11:30.601 Warning, WARNING: Failed to init the controller (attempt 2)
    2016-01-21 15:11:35.605 Info, Opening controller /dev/ttyUSB0
    2016-01-21 15:11:35.606 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-21 15:11:35.629 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2016-01-21 15:11:35.629 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2016-01-21 15:11:35.629 Warning, WARNING: Failed to init the controller (attempt 3)
    2016-01-21 15:11:40.632 Info, Opening controller /dev/ttyUSB0
    2016-01-21 15:11:40.677 Info, Trying to open serial port /dev/ttyUSB0 (attempt 1)
    2016-01-21 15:11:40.677 Error, ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
    2016-01-21 15:11:40.677 Error, ERROR: Failed to open serial port /dev/ttyUSB0
    2016-01-21 15:11:40.677 Warning, WARNING: Failed to init the controller (attempt 4)
    2016-01-21 15:11:40.677 Detail, contrlr, Notification: DriverFailed
    2016-01-21 15:11:40.677 Warning, WARNING: Tried to write driver config with no home ID set
    2016-01-21 15:11:40.677 Info, mgr, Manager::WriteConfig completed for driver with home ID of 0x00000000

    #2541

    dplg92
    Participant

    Bonsoir
    Avez vous pu trouver quelque chose concernant mon problème!!
    Je suis toujours bloqué

    Contrairement à mon message précédent, le LOG du service est revenu à la normal.
    Mais toujours impossible de voir la clé Z-wave, et encore moins le périphérique Qubino connecté à l’un de mes radiateurs

    Merci de votre aide!

    #2542

    dplg92
    Participant

    Juste pour être sur, et ne pas embêter tout le monde.
    Sur cette page, on doit bien voir apparaitre la clé et les périphériques?

    service Zwave

    #2543

    K.Rens
    Admin bbPress

    1) IMAtools
    Tu dois démarrer votre ordinateur avec le clé usb insérée.
    Après launch imatools et cliquer sur “settings” menu et activez le porte COMx
    Après clique sur “Full Network” pour voir votre clé et tout les appareils associée au clé usb.

    2) Si votre appareil n’apparaît pas dans IMAtool, tu peut l’ajouter avec “Add node”
    Après commence le mode inclusion du radiateurs, il doivent apparaître avec feu vert.
    Ça peut prendre 15-20 minutes.

    Vérifiez aussi si votre clé usb est du même fréquence radio du radiateurs.
    8xx mhz

    • Cette réponse a été modifiée le il y a 1 an et 9 mois par  K.Rens.

    Kind regards,
    K.Rens

    #2545

    dplg92
    Participant

    bonsoir,
    merci pour ce retour mais malheureusement, je n’ai pas accès à Full Network…
    Tous les boutons sont grisés.
    Je suis bloqué! je ne sais pas quoi faire….

    Et oui, la clé et l’équipement radiateur sont sur la meme fréquence.

    #2571

    K.Rens
    Admin bbPress

    Que ce que tu vois si tu clique sur “settings” après le reboot?
    L’option comm n’est pas la dans le IMAtools?

    Kind regards,
    K.Rens

15 sujets de 1 à 15 (sur un total de 15)

Vous devez être connecté pour répondre à ce sujet.