[Résolu] ZWave Log does not stop…

Domotica gratuit Forums Report a bug ZWave Log does not stop…

Mots-clés : 

Ce sujet a 9 réponses, 3 participants et a été mis à jour par  LaplaceII, il y a 1 mois et 1 semaine.

10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #11859

    LaplaceII
    Participant

    Hello,
    In the service för zwave is an option to stop the logging. If I choose ‘no’ the Logging doesn’t stop. Andy hints to stop the logging?
    Thanks in Advance!
    Michael

    #11860

    K.Rens
    Admin bbPress

    Hi,

    Why would you want to do that?
    If you really want it, you can change it inside the services/zwave/config folder.
    There is a zwave config file, allowing you to set the log level.
    Or you can via ssh make the log file read-only:
    sudo chmod 444 /volume1/web/PulseStation/Services/zwave/zwave.log
    file
    The option to set logging to no, only reduces it a little bit.

    Kind regards,
    K.Rens

    #11861

    LaplaceII
    Participant

    Hello Koen,

    thanks for you reply ande hints!
    Yes there is a reason for it: The OZW_Log.txt file becomes bigger during the system is running (>100MB). Eventhough if I delete the content by using this option within PulseStation the file size drops to zero. But if the next log is initiated the filesize is again >100MB…

    Regards
    Michael

    #11863

    K.Rens
    Admin bbPress

    Another solution is using blocky to just empty the log again.
    You can every night for instance empty this file.

    Kind regards,
    K.Rens

    #11864

    LaplaceII
    Participant

    Hello Koen,

    thanks for the response. I use blockly to delete the logs. It works fine for the core, scene and weather log. But for the zwave log I have the effect I described above.
    Am I the only one with this issue? Then its up to me to solve it. But if there are other users with the same issue it could be a bug….Would be great to hear experiences of other users…

    Regards
    Michael

    #11865

    djandib
    Participant

    Hi,
    @Koen: I can confirm what Michael says: The template “logs delete” has a problem with zwave.
    My scene “Log delete” runs every night at 3:00.

    Here is the actual output:
    ���������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������2018-03-09 03:03:02.684 Detail, Node041, Received: 0x01, 0x0c, 0x00, 0x04, 0x00, 0x29, 0x06, 0x31, 0x05, 0x04, 0x22, 0x00, 0x00, 0xca
    2018-03-09 03:03:02.684 Detail,
    2018-03-09 03:03:02.684 Info, Node041, Received SensorMultiLevel report from node 41, instance 1, Power: value=0.0W
    2018-03-09 03:03:02.684 Detail, Node041, Refreshed Value: old value=0.0, new value=0.0, type=decimal
    2018-03-09 03:03:02.684 Detail, Node041, Changes to this value are not verified

    #11870

    LaplaceII
    Participant

    Thanks for your confirmation.
    I have the same symbols in my log. As is wrote the file size is getting bigger and bigger even though if it es cleared (independent if the deletion is done by blocky, in the zwave menu)
    Regards
    Michael

    #11875

    LaplaceII
    Participant

    Hello,
    is there a workaround planned?
    Regards
    Michael

    #11879

    K.Rens
    Admin bbPress

    You can disable the logging inside zwave itself:
    https://github.com/OpenZWave/open-zwave/blob/master/config/options.xml

    Just put true to false in the options.xml file for logging.

    You can find it in the folder: PulseStation\services\zwave\config

    Kind regards,
    K.Rens

    #11880

    LaplaceII
    Participant

    Thanks for the hint Koen!

10 sujets de 1 à 10 (sur un total de 10)

Vous devez être connecté pour répondre à ce sujet.