1.3.1 on Synology 1511+ 6.0.2 = "file not found"

Gratis domotica Forums How can I …? Synology NAS 1.3.1 on Synology 1511+ 6.0.2 = "file not found"

Dit onderwerp bevat 6 reacties, heeft 3 stemmen, en is het laatst gewijzigd door Avatar putimir 3 jaren geleden.

7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)
  • Auteur
    Berichten
  • #3847
    Avatar
    putimir
    Bijdrager

    Hi all, after installation, i’m getting “Sorry, the page you are looking for is not found.” pages while trying both URLs: http://synology/PulseStation/administration and http://synology/PulseStation/

    I checked the Nginx log and sure enough, there are errors:
    2016/11/08 23:07:58 [error] 13743#13743: *23907 open() “/etc/nginx/html/PulseStation” failed (2: No such file or directory), client: 192.168.1.2, server: _, request: “GET /PulseStation HTTP/1.1”
    2016/11/08 23:16:08 [error] 13742#13742: *28235 open() “/etc/nginx/html/PulseStation/administration” failed (2: No such file or directory), client: 192.168.1.2, server: _, request: “GET /PulseStation/administration HTTP/1.1”

    The installation seems went ok:

    11/08/16-23:07:28 Installation started
    11/08/16-23:07:28 PulseStation’s web interface installed.
    11/08/16-23:07:28 DSM Major version : 6.
    11/08/16-23:07:28 DSM6 -> Default PulseStation’s services installed.
    11/08/16-23:07:28 Configuration done.
    11/08/16-23:07:28 Shortcut created.
    11/08/16-23:07:28 Script to restart application after reboot done.
    11/08/16-23:07:28 Drivers installed.
    11/08/16-23:07:29 Drivers loaded.
    11/08/16-23:07:29 Installation successfull.

    Any ideas, guys?

    Thanks, Jure

    #3851
    Miss Laura
    Miss Laura
    Moderator

    I do not understand why it points to /etc/nginx/html/PulseStation
    PulseStation on a Synology device is installed in: /volume1/web/PulseStation/

    Did you install it via the package center?
    Did you install webstation first?

    Have fun,
    Laura

    #3856
    Avatar
    putimir
    Bijdrager

    Hi Laura, thank you for answering, hmm…as far as I know nginx is the default web server on synology (webstation). In it’s default config it serves files from /etc/nginx/html/. So vithout any virtual servers defined it looks for the files there…

    If the files are located in /volume1/web/PulseStation/, then I think it is required do define a virtual server on nginx pointing to that dir…(given that default web server is used by PulseStation – right?)

    And,

    yes, I installed pulsestation via package center…

    #3857
    Avatar
    putimir
    Bijdrager

    Oh, yes, I have NOTHING in volume1/web/PulseStation/, but there are files in /var/services/web/PulseStation/, that seem like it:

    ash-4.3# ls -la /var/services/web/PulseStation/
    total 96
    drwxrwxrwx 19 root root 4096 Nov 9 21:32 .
    drwxr-xr-x 3 root root 4096 Nov 9 21:32 ..
    drwxrwxrwx 11 root root 4096 Nov 9 21:32 administration
    drwxrwxrwx 3 root root 4096 Nov 9 21:32 blockly_src
    -rwxrwxrwx 1 root root 1592 Nov 9 21:32 .buildpath
    -rwxrwxrwx 1 root root 185 Nov 9 21:32 .classpath
    drwxrwxrwx 4 root root 4096 Nov 9 21:32 css
    drwxrwxrwx 4 root root 4096 Nov 9 21:32 data
    drwxrwxrwx 7 root root 4096 Nov 9 21:32 help
    drwxrwxrwx 2 root root 4096 Nov 9 21:32 images
    -rwxrwxrwx 1 root root 4094 Nov 9 21:32 index.html
    drwxrwxrwx 2 root root 4096 Nov 9 21:32 lang
    drwxrwxrwx 12 root root 4096 Nov 9 21:32 lib
    drwxrwxrwx 3 root root 4096 Nov 9 21:32 modules
    drwxrwxrwx 2 root root 4096 Nov 9 21:32 pages
    -rwxrwxrwx 1 root root 1100 Nov 9 21:32 .project
    drwxrwxrwx 5 root root 4096 Nov 9 21:32 services
    drwxrwxrwx 2 root root 4096 Nov 9 21:32 .settings
    drwxrwxrwx 2 root root 4096 Nov 9 21:32 setup
    drwxrwxrwx 2 root root 4096 Nov 9 21:32 static
    -rwxrwxrwx 1 root root 111 Nov 9 21:32 .tern-project
    drwxrwxrwx 2 root root 4096 Nov 9 21:32 tmp
    drwxrwxrwx 2 root root 4096 Nov 9 21:33 usr
    drwxrwxrwx 3 root root 4096 Nov 9 21:32 utils

    #3858
    Avatar
    putimir
    Bijdrager

    Oh man, one more thing: packace center says service is stopped AND it cannot be started…but I think it’s running (which one is considered as “service” – core?):

    ash-4.3# netstat -lap | grep 4020
    tcp 0 0 0.0.0.0:4020 0.0.0.0:* LISTEN 29876/core

    ash-4.3# ps -ef | grep core
    root 1001 21159 0 21:38 pts/2 00:00:00 grep core
    http 12687 1 0 Nov08 ? 00:00:02 /var/services/web/PulseStation/services/core/../identification/identification
    http 12692 1 0 Nov08 ? 00:00:02 /var/services/web/PulseStation/services/core/../identification/identification
    http 29876 1 0 21:32 ? 00:00:00 /var/services/web/PulseStation/services/core/core
    http 30147 1 0 21:33 ? 00:00:00 /var/services/web/PulseStation/services/core/../scene/scene

    #3859
    Avatar
    K.Rens
    Sleutelbeheerder

    Don’t trust the status inside the package center.
    Due to permission rights Package center cannot see whether it’s running or not.

    Strange that iyour synology is using nginx by default. All others I’ve seen before are using apache by default for webstation.
    If you switch to Apache and reinstall pulseStation it will probably work.
    Otherwise just create a virual link to the correct folder.

    Kind regards,
    K.Rens

    #3860
    Avatar
    putimir
    Bijdrager

    Hi K.Rens! Yes, that was it…I installed Apache package and made it “HTTP back-end-server” and immedieately PulseStation pages became available! 😀 yeey…

    Thank you both again for your time! Cheers!

    Now to the real stuff 😉

    Goodnight!

7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.