Teach PulseStation: I`m at home

Gratis domotica Forums How can I …? Synology NAS Teach PulseStation: I`m at home

Dit onderwerp bevat 12 reacties, heeft 5 stemmen, en is het laatst gewijzigd door  djandib 2 jaren, 6 maanden geleden.

13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)
  • Auteur
    Berichten
  • #2861

    djandib
    Bijdrager

    Hi,
    how can I teach my PulseStation, that I`m (my mobile is) at home?

    Scene:
    If I`m at home, then open the rollo

    Available Hardware:
    -Android mobile with Imperihome
    -Synology NAS with Z-Wave ZME_UZB1 Me USB Stick
    -Fibaro Jalousiesteuereinsatz Rev 02, FIB_FGRM-222
    -of course: PulseStation

    Any idea?
    Thank you

    #2865

    LoJaume
    Bijdrager

    I suppose “at home” can be an IFTTT trigger, and I think blocky supports IFTTT.
    Perhaps you can investigate about it.

    #2866

    djandib
    Bijdrager

    Yes, i thought about this, but I didn`t find the right connection…
    My thoughts:
    – At my mobile (DJ) is Imperihome installed
    – Imperihome knows my Wifi-Net (djathome)
    – Imperihome works together with Pulsestation

    So maybe I need at PulseStation in Blocky something like:
    if Imperihome is recognized on mobile (DJ)
    then set variable DJ@Home=1

    Possible?

    #2871

    coldbringer
    Bijdrager

    Hi, you can tell PulseStation that you’re at home using a ping to your mobile device.

    1. Install a web server app on your android mobile (“Paw Server” works fine). You will need this to reply to the ping from PulseStation.
    2. Set up a virtual device “Virtual Ping” in PulseStation and configure the correct private IP address and port.
    3. Within Blockly, you can now use blocks for your virtual device and query the “ping.status” property which will return true when your mobile is logged into your WiFi, and return false if not.

    This works pretty well, as long as you never turn off your mobile while at home…

    cheers
    Carlos

    • Deze reactie is gewijzigd 2 jaren, 7 maanden geleden door  coldbringer.
    #2877

    LoJaume
    Bijdrager

    I see there are IFTTT channels -like Life360 or Foursquare- that can be used as “I’m at home” ifttt events. They use the GPS position, so, is not as precise as ping solution.

    #2878

    K.Rens
    Sleutelbeheerder
    #2892

    djandib
    Bijdrager

    @ K.Rens:
    “Inside the properties of this device, fill in the IP and port of your device.”
    This is the IP of my mobile connected to my Fritz.Box right?
    e.G. 192.168.178.69
    Inside Fritz.box my mobile has always the same IP…
    And for this IP I open the “12345” port in the Fritz.box
    Right?

    #2893

    redxeagle
    Bijdrager

    @djandib not only.

    The implementation (as i understand it) behind: Pulsestation make an http request for your configured ip adress.

    So just open a browser and try http://[YOUR-IP]:[YOURPORT]
    in case you got any result (200 response) then you computer/android device is running. otherwise not.

    Thats why you need to have any WebServer running. Under Windows 7/10 the simplest one is Internet Information Service from Microsoft themself.

    #2901

    djandib
    Bijdrager

    Everyday one step ahead…
    I think I got it yesterday work!

    Next step: Use blocky for “I`m @ home”
    I wrote a simple rule
    ***
    IF COMPERATOR “Mobile” ping.status = “TRUE”
    DO Device “Lamp” SWITCH new value “TRUE”
    ELSE Device “Lamp” SWITCH new value “FALSE”
    ***
    And it works! Almost… If I turn on WLAN at home at my mobile, the Lamp turns on.
    But after a few seconds lamp turns off again….
    Nice effect, but not the situation I want…

    Any ideas?

    #2902

    K.Rens
    Sleutelbeheerder

    Your phone probably has a setting to disable wifi when he goes into sleep mode.
    Inside the phone wifi settings you can activate to keep wifi enabled while sleeping.

    Kind regards,
    K.Rens

    #2907

    djandib
    Bijdrager

    No, not the solution. Phone is activated in my hand. No sleep-mode
    @K.Rens: Blockyscene is right?

    #2908

    djandib
    Bijdrager

    You wrote in another post, that the ping is made once a minute.
    Seems pulsestation does not “save/remember” the status of ping for that time…

    #2909

    djandib
    Bijdrager

    I think I solved the Problem now this way:
    2 Scenes:
    1)
    IF COMPERATOR “Mobile” ping.status = “TRUE”
    DO Device “Lamp” SWITCH new value “TRUE”
    2)
    IF COMPERATOR “Mobile” ping.status = “FALSE”
    DO Device “Lamp” SWITCH new value “FALSE”

    Seems it works…
    Any comments from the cracks?

13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.