Trouble including the Fibaro Smoke Sensor

Gratis domotica Forums How can I …? Synology NAS Trouble including the Fibaro Smoke Sensor

Dit onderwerp bevat 52 reacties, heeft 5 stemmen, en is het laatst gewijzigd door Mika Mika 2 jaren, 11 maanden geleden.

15 berichten aan het bekijken - 31 tot 45 (van in totaal 53)
  • Auteur
    Berichten
  • #1237

    coldbringer
    Bijdrager

    Hi, here’s some news about my Smoke Sensors. From one day to the next both of them went to “Node is failed”. The properties tabs are now entirely blank. I didn’t change anything.

    Would be great if you could look into that some time

    #1238

    K.Rens
    Sleutelbeheerder

    Hi,

    The smoke sensor I purchased for testing has just arrived.
    For me it included right away and all details are available:
    http://screencast.com/t/BeymXhE6baT

    I will keep monitoring it during the coming days to see whether it starts failing.

    Kind regards,
    K.Rens

    Kind regards,
    K.Rens

    #1243

    coldbringer
    Bijdrager

    Interesting 🙁

    Did you manage to change the configuration values regarding the temperature? Reporting inverval and hysteresis?

    #1244

    coldbringer
    Bijdrager

    Maybe my Z-wave controller is inappropriate? I have the aeon labs stick (z-wave plus)

    Another issue is, when I click on “Add device” or “Remove device” in the z-wave service menu of PulseStation, there is no reaction. That doesnt seem right either.

    • Deze reactie is gewijzigd 3 jaren, 1 maand geleden door  coldbringer.
    #1248

    K.Rens
    Sleutelbeheerder

    Hhmm, I have the impression the temperature is not updated that often.
    It’s still on 22,4.
    I’ll check again tomorrow morning to compare it.
    After I confirm it does not move, I will try changing the reporting interval.

    Kind regards,
    K.Rens

    #1284

    K.Rens
    Sleutelbeheerder

    Hi,

    I have the impressions temperature sensor and reporting interval are sort of working.
    There is only a difference of 0,2°C when I put the 2 sensors next to eachother. 🙂

    I changed the report interval to 3600 and now it looks like it updates every 30 minutes.
    Note: you only see the value has been changed after the next wake-up of the device, so it may look as if the value does not get updated, but actually it does on the next wake up.

    Kind regards,
    K.Rens

    #1286

    coldbringer
    Bijdrager

    Hi, yes, the temperature values are updated – that used to be fine. But only in full 1° steps. I cannot modify the parameters to change that. Did that work for you? My onservation: On first detection the temperature is 20.6 degrees => all temperatures ever measured will be X.6 degrees, unless you change the temperature report hyteresis. But I can’t, tried a hundred times.

    By the way, now I have both sensors completely out of order. I did a reset on the Z-Stick, which you suggested upon adding of new devices in another post that I read. Both sensors and both Roller Shutters disappeared and wouldn’t reappear. I reset each sensor, Properties tab remains blank. No results. The Controller state says “Node is failed”. I have no clue, the whole configuration is really inconvenient and not reliable.

    Mika kept repeating, that “Node is failed” is normal because I’m looking at a wake-up device. Wouldn’t it be more transparent to display “Node is asleep”??? When I browse through the ZWave Service’s logfile, I find the following entries:

    2015-09-25 10:13:26.428 Info, Node002, WARNING: ZW_SEND_DATA failed. No ACK received – device may be asleep.
    2015-09-25 10:13:26.428 Info, Node002, Node 2 has been marked as asleep
    — That makes sense.

    2015-09-25 10:20:36.796 Warning, Node002, WARNING: Received reply to FUNC_ID_ZW_IS_FAILED_NODE_ID – node 2 failed
    — That is totally misleading. Asleep <> Failed, when you ask me.

    Anyways. It would be great if you had some more hints for me.

    #1298

    coldbringer
    Bijdrager

    Hey, me again. Now both Smoke Sensors have decided to report a temperature again. I haven’t changed a thing. They have been in 2 meters range from the controller all the time. The Properties tab now shows 4 pages of parameters, but not the full 10 pages with all Fibaro parameters. I find this very confusing

    #1300

    K.Rens
    Sleutelbeheerder

    I’ve been following the temperature sensor on the smoke sensor and it’s always about 2°C warmer then the motion sensor of Fibaro.
    But the digit behind the 22.x does change.
    It changed from ,2 to ,4 and I’ve also seen ,9.
    So that does seem to work.

    Next up is trying to play with the parameters to report exactly the same temperature as the motion sensor.

    Fyi: I did not suggest to reset the USB key, only reset the config inside PulseStation, that’s a different button in the same panel.

    I checked and I have 7 pages of parameters, with 5 parameters per page.
    That’s indeed a bit weird.

    I’m using following usb key:
    http://www.z-wave.me/index.php?id=28

    Which one are you on? And do you by any chance know whether it’s a recent key or an older one?

    Note: I’m on the beta testing group of PulseStation, so maybe I’m running on a newer version of the openzwave library.

    Kind regards,
    K.Rens

    #1315

    coldbringer
    Bijdrager

    I am using an Aeon Labs Z-Stick Gen5, packaging says 2014.

    #1335

    coldbringer
    Bijdrager

    Hi, did you manage to update the configuration values of the smoke sensor? I spent some more time and I thought I’d share my findings.

    I deleted the config files and both smoke sensors were found afterwards, but the properties tabs were both empty. On Node002 I pushed the button to wake up the sensor and apparently it worked. See log entry:

    2015-10-02 14:21:57.650 Info, Node002, Received Wakeup Notification from node 2
    2015-10-02 14:21:57.650 Info, Node002, Node 2 has been marked as awake

    Even the correct device type was detected:
    2015-10-02 14:26:10.984 Info, Node002, Opening config param file /volume1/web/PulseStation/services/core/../zwave/config/fibaro/fgsd002.xml
    2015-10-02 14:26:11.003 Info, Node002, Received manufacturer specific report from node 2: Manufacturer=FIBARO System, Product=FGSD002 Smoke Sensor

    Looks good. In the above mentioned config file I recognized all the parameter that I expect to be displayed. But again, I will only see 4 pages of generic parameter, no Fibaro Smoke Detector specific stuff.

    Now I tried to update the wake up interval from 21600 to 3600. Log file says:
    2015-10-02 14:26:10.984 Info, Node002, Opening config param file /volume1/web/PulseStation/services/core/../zwave/config/fibaro/fgsd002.xml
    2015-10-02 14:26:11.003 Info, Node002, Received manufacturer specific report from node 2: Manufacturer=FIBARO System, Product=FGSD002 Smoke Sensor

    Looks good. But now, when I push the button, the device doesn’t wake up. Node is failed. Terrible. I get the impression that it’s only a little issue with config files or so, but it simply doesn’t work.

    Any new ideas? Many thanks.

    #1338

    coldbringer
    Bijdrager

    Hello, I made a copy/paste mistake in my last posting. Here is what the logfile says when I try to update the wake-up interval. Apparently, the device wakes up, then the command ZW_SEND_DATA is executed, but the smoke sensor doesn’t reply to that (WARNING: ZW_SEND_DATA failed. No ACK received – device may be asleep.)

    2015-10-03 11:26:48.930 Detail, Node003, Queuing (Controller) Has Node Failed
    2015-10-03 11:26:48.930 Info, Requesting whether node 3 has failed
    2015-10-03 11:26:48.930 Detail, contrlr, Queuing (Command) Has Node Failed?: 0x01, 0x04, 0x00, 0x62, 0x03, 0x9a
    2015-10-03 11:26:48.930 Detail,
    2015-10-03 11:26:48.930 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x62) – Has Node Failed?: 0x01, 0x04, 0x00, 0x62, 0x03, 0x9a
    2015-10-03 11:26:48.934 Detail, contrlr, Received: 0x01, 0x04, 0x01, 0x62, 0x00, 0x98
    2015-10-03 11:26:48.934 Detail,
    2015-10-03 11:26:48.934 Warning, Node003, Received reply to FUNC_ID_ZW_IS_FAILED_NODE_ID – node 3 has not failed
    2015-10-03 11:26:48.934 Error, Node003, WARNING: node revived
    2015-10-03 11:26:48.934 Detail, Node003, AdvanceQueries queryPending=1 queryRetries=0 queryStage=SecurityReport live=1
    2015-10-03 11:26:48.934 Detail, contrlr, Expected reply was received
    2015-10-03 11:26:48.934 Detail, contrlr, Message transaction complete
    2015-10-03 11:26:48.934 Detail,
    2015-10-03 11:26:48.934 Detail, contrlr, Removing current message
    2015-10-03 11:26:48.958 Info, mgr, Manager::WriteConfig completed for driver with home ID of 0xd889e42b
    2015-10-03 11:26:58.374 Info, Node003, Value::Set – COMMAND_CLASS_WAKE_UP – Wake-up Interval – 0 – 1 – 3600
    2015-10-03 11:26:58.374 Detail, Node003, Queuing (WakeUp) WakeUpCmd_IntervalSet (Node=3): 0x01, 0x0d, 0x00, 0x13, 0x03, 0x06, 0x84, 0x04, 0x00, 0x0e, 0x10, 0x01, 0x25, 0x7c, 0x22
    2015-10-03 11:26:58.374 Detail, Node003, Queuing (Send) WakeUpCmd_IntervalGet (Node=3): 0x01, 0x09, 0x00, 0x13, 0x03, 0x02, 0x84, 0x05, 0x25, 0x7d, 0x3d
    2015-10-03 11:26:58.374 Detail,
    2015-10-03 11:26:58.375 Info, Node003, Sending (WakeUp) message (Callback ID=0x7c, Expected Reply=0x13) – WakeUpCmd_IntervalSet (Node=3): 0x01, 0x0d, 0x00, 0x13, 0x03, 0x06, 0x84, 0x04, 0x00, 0x0e, 0x10, 0x01, 0x25, 0x7c, 0x22
    2015-10-03 11:26:58.385 Detail, Node003, Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
    2015-10-03 11:26:58.385 Detail, Node003, ZW_SEND_DATA delivered to Z-Wave stack
    2015-10-03 11:27:02.593 Detail, Node003, Received: 0x01, 0x07, 0x00, 0x13, 0x7c, 0x01, 0x01, 0xa5, 0x32
    2015-10-03 11:27:02.593 Detail, Node003, ZW_SEND_DATA Request with callback ID 0x7c received (expected 0x7c)
    2015-10-03 11:27:02.594 Info, Node003, WARNING: ZW_SEND_DATA failed. No ACK received – device may be asleep.

    #1383

    coldbringer
    Bijdrager

    Hello, some more details. I manually edited the xml files to get all 7 pages for the smoke sensor configuration – and it worked. The whole section <CommandClass id=”112″ name=”COMMAND_CLASS_CONFIGURATION” version=”1″ request_flags=”4″> was blank, I inserted the configuration from the Fibaro folder under services/zwave.

    Next, I restarted the zwave service. All parameters appeared, but all values were read-only. Another restart later I could modify the values. So I tried again to change the value “Temperature report hysteresis” to 1. The command was queued at first, and was executed on the next wake-up:

    2015-10-06 22:20:53.558 Info, Node002, Value::Set – COMMAND_CLASS_CONFIGURATION – Temperature report hysteresis – 21 – 1 –
    2015-10-06 22:20:53.558 Info, Node002, Configuration::Set – Parameter=21, Value=1 Size=1
    2015-10-06 22:20:53.558 Detail,
    2015-10-06 22:20:53.558 Detail, Node002, Queuing (WakeUp) ConfigurationCmd_Set (Node=2): 0x01, 0x0c, 0x00, 0x13, 0x02, 0x05, 0x70, 0x04, 0x15, 0x01, 0x01, 0x25, 0x38, 0x9b
    2015-10-06 22:20:53.558 Detail,
    2015-10-06 22:20:53.558 Detail, Node002, Queuing (WakeUp) ConfigurationCmd_Get (Node=2): 0x01, 0x0a, 0x00, 0x13, 0x02, 0x03, 0x70, 0x05, 0x15, 0x25, 0x39, 0x9b
    2015-10-06 22:23:39.207 Detail, Node002, Received: 0x01, 0x0c, 0x00, 0x04, 0x00, 0x02, 0x06, 0x31, 0x05, 0x01, 0x22, 0x00, 0xd3, 0x37
    2015-10-06 22:23:39.207 Detail,
    2015-10-06 22:23:39.207 Info, Node002, Received SensorMultiLevel report from node 2, instance 1, Temperature: value=21.1C
    2015-10-06 22:23:39.207 Detail, Node002, Initial read of value
    2015-10-06 22:23:39.448 Info, Notification: Value Changed – Add DB Record for device id zwave-2 and value id 49-user-decimal-1-1
    2015-10-06 22:23:39.579 Info, mgr, Manager::WriteConfig completed for driver with home ID of 0xd889e42b

    All of this looks perfect, and the reported temperature indicates that the changes have been applied (new temperature value 21.1C, all previous values had .0C). But when I go back to the properties tab of the smoke sensor, the value for temperature report hysteresis is 10 again, not 1. Obviously the value was not updated in the smoke sensor.

    @K.Rens, have you made any progress on this issue?

    Thanxalot
    Carlos

    #1617

    guillaume
    Bijdrager

    Hello,
    I am experiencing the same issue. At some time I was able to add the device but the version was never recognized. So far I was not able to make it work…

    G

    #1620

    coldbringer
    Bijdrager

    It works with the beta version of PulseStation that I am using now. Most of my issues are resolved: devices send temperature, devices are marked as “NodeOK” even if they are asleep, the wake-up detection is fine, and I have succesfully modified a couple of parameters.

15 berichten aan het bekijken - 31 tot 45 (van in totaal 53)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.