yan.pelletier

Aangemaakte reacties

6 berichten aan het bekijken - 1 tot 6 (van in totaal 6)
  • Auteur
    Berichten
  • yan.pelletier
    Bijdrager

    Thank you!

    yan.pelletier
    Bijdrager

    None of this made any difference, but I finally found the problem :

    /etc/php/conf.d/extensions.ini was in read-only by root.

    Doing a “chmod 644” on the file fix everything!

    I have no idea why this file had the wrong rights. One thing for sure, I didn’t touch that before.

    Thank you for your help!

    yan.pelletier
    Bijdrager

    Hi,

    I found this in the logs when running with “http” user :

    • PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/modules/mysqlnd.so’ – /usr/lib/php/modules/mysqlnd.so: undefined symbol: BIO_new_mem_buf in Unknown on line 0
    • PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/modules/mysql.so’ – /usr/lib/php/modules/mysql.so: undefined symbol: _mysqlnd_fetch_lengths in Unknown on line 0
    • PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/modules/mysqli.so’ – /usr/lib/php/modules/mysqli.so: undefined symbol: mysqlnd_get_client_info in Unknown on line 0
    • PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/modules/pdo_mysql.so’ – /usr/lib/php/modules/pdo_mysql.so: undefined symbol: mysqlnd_get_client_info in Unknown on line 0

    If I use “root” user errors are gone.

    All 4 files are readable and executable by “http” user…

    Ideas?

    Thank you!

    yan.pelletier
    Bijdrager

    Hi,

    I’ve tried your suggestion, but I’m having the same problem.

    I’ve tried running the “core” service from console using “http” and everything work like a charm. As soon as I use the web interface to start everything, nothing work anymore.

    Anymore ideas?

    In reactie op: Unable to edit or delete virtual devices #1513
    yan.pelletier
    Bijdrager

    Great, that was it! Thank you!

    All my Z-Wave/Imperihome was working without MariaDB!

    I would suggest a validation, a warning or something to let user know that there’s a dependency…

    Thank you again!

    In reactie op: Unable to edit or delete virtual devices #1486
    yan.pelletier
    Bijdrager

    I forgot to say…

    I’m trying to setup a “LOV” device. Values in the “General” tab are saved, but none of the “Properties” tab are.

    Thank you!

6 berichten aan het bekijken - 1 tot 6 (van in totaal 6)